Assistance with hiss diagnosis

Hello - I will preface this by noting I don’t really know what I’m doing…

I’m recording audio for short (3-5 minute) video tutorials. I’m having a consistent problem with hiss on my recording. I don’t think it’s from any noise in my environment, because it doesn’t show on the mic meter in Audacity. Feel free to correct me if I could be mistaken on that point.

I’ve attached a sample recording. I’ve played it back on a few different computers, and through the speakers the hiss is not very evident but it’s immediately apparent when listening through headphones. For my purposes I can mostly resolve it using Noise Reduction, but the end result isn’t as good as I would like it. And, more importantly, it’s really annoying me that I can’t figure out the cause.

I’m using a Samson G Track USB mic. My machine is a Windows 7 64 bit Toshiba Satellite laptop. I’m running Audacity 2.0.6.

After having done some research here and other places, I’ve tried: moving the mic as far away from the computer as possible… making sure the mic cable isn’t running alongside, or even resting close to, any power cables… keeping my cell phone in the other room… turning off all lights… turning off all other electronics (printer, other computer) in the room… running the laptop off of battery instead of power cable… crossing my fingers while hitting Record… and sacrificing a donut to the audio gods.

I’m thinking maybe an issue with the mic itself, or maybe a crappy soundcard in the laptop, but don’t know enough to say with any certainty that upgrading those will help. I’ve tried recording on a couple other machines, with similar results… maybe they all have crappy soundcards though too. Hoping someone can give me some guidance.

If I’ve left out any info that would be helpful for a diagnosis, please let me know.

Thank you.

Indeed your sample is noisier than I would expect.

If you are not using the “instrument” input I would make sure that the instrument volume knob is turned all of the way to it’s minimum setting.

That mic also has a clip indicator according to it’s instruction manual. The power LED will flash red if it is clipping. So I would recommend turning up the microphone gain knob while speaking in your normal tone until you see that LED start to flash, then back off till you can’t make it flash with your most excited speech.

and sacrificing a donut to the audio gods.

What kind of donut?

It’s one of these, right?

I really liked that thing while I had it. I borrowed it from a guitarist/singer and he liked it and I assume he’s still using it.

As above, it will do a number of different jobs so make sure your instrument input is turned down so it doesn’t contribute noise. As a fuzzy rule, once the sound becomes digital (USB) it’s relatively bulletproof. It’s the analog system that contributes the noise. From the time your voice sound hits the diaphragm (the round thing just behind the grill) until the analog to digital converter, the processing and amplification is pure analog. If your cellphone is going to get into the sound, that’s where it’s going to do it.

It’s a side-fire microphone and you should be singing into the logo in that picture.

Because there is no board operator or sound mixing desk, it’s up to you to do those jobs. You should be as loud as possible without causing sound damage. The hiss is generally a fixed volume and it’s up to you to get a lot louder than that. The microphone is a hypercardioid which means in English, it doesn’t pick up sound from any direction except right in front.

As a test, you might crank the MIC control all the way up and see how loud you can talk without causing the overload light to flash. That will give you a feel for how loud to get during a performance. If this is your first microphone, you might naturally assume you can be three or four feet away from the microphone and perform in a quiet, relaxed voice.

Probably not.

Wynonna is singing one of the tunes from “Lilo and Stitch” in that shot, and she’s not bashful about it (attached).

The light might be a “Too Late” indicator. You can get a much better idea how loud to get with the Audacity red recording meters.

You should make the meters bigger than the default so you can see them. Click on the right side and pull. We picked -6 as a target. That gives you a comfortable margin for error before you overload (-0dB-). It’s a fuzzy target, so don’t hyperventilate if you don’t hit it perfectly.


Thanks both of you for the replies, much appreciated.

kozikowski, yep that’s the mic I have. And the donut was a chocolate raised with sprinkles. Maybe the audio gods prefer jelly-filled?

I’ve got the Instrument volume down all the way on the mic. I’m only recording vocals (speaking, not singing). I’ve got the mic gain button set so it’s pretty consistently hitting -6 while using my normal speaking voice. I expanded the levels as you suggested. I read somewhere that making the “hang loose” sign with your hand, with your pinky at the mic and your thumb at your mouth, was a good indicator for how far away you should be, so that’s what I’ve been doing. Any closer and it really picks up my p’s (plosives?) and such. At some point I may buy a screen…

So if unless I’m missing something, it sounds like I don’t have any obvious problems in my setup, from what we’ve covered so far… so I’ve still got a mystery on my hands?

Thanks again.

If it’s a USB mic it is not using the “crappy” soundcard to record the sound : the Analog-Digital conversion is going on inside the mic body, not via the computer’s built-in soundcard.

When you are recording Audacity could be also be simultaneously recording from other devices as well as the USB microphone , (e.g. “line in”).
Go to Windows recording devices and disable all other recording devices , as they could be contributing hiss noise to your recording.

[ right mouse click on the loudspeaker icon , (next to the clock), then left mouse click on “Recording Devices” ]
Windows [Vista] recording devices.png

Thanks for letting me know that it wasn’t using the soundcard, and for the tip about the other recording devices.

I disabled the other recording devices and tried recording again. Still having the hiss.

Experiment with adjusting the “input volume” in Audacity in conjunction with the mic gain knob on the body of the mic : as you turn one up, turn the other one down, to have a constant recording level (of about -3dB).
At some point during that recording-experiment the hiss-level relative to the voice-level will be at a minimum.
input volume to max.gif

HISS HAPPENS (esp. with cheap rec. equip.–I know). That being said, one fix I’ve found is the Audacity Noise Removal effect, which has been tightened up on the new version (2.0.6) – Read the help/manual, which gives specific advice/recommended settings for the NR effect in regards to hiss.

Apparently less hiss is possible than kwartz is currently getting with the “Samson G Track USB mic”.

I swear the one I was using didn’t have problems like that and the real owner never mentioned it. Yes, testing is in order. Start a recording and run the microphone MIC control from one end to the other. See what happens to the hiss level. Also, make sure the control is working.

Announce: “This is the control at minimum.” [turn the control up] “This is the control at maximum.”

I wonder if my guitar/singer still has his…


There are two other considerations: Building a complex analog device isn’t easy and each part has a tolerance. I built a big, take-no-prisoners microphone preamplifier and I hand-selected some of the parts because about half of the ones I got from the supplier may have been in tolerance, but either had wimpy amplification or were too noisy for the job.

That and it’s possible the mic is broken. Neither of those is likely, but then having one of these fail like yours isn’t likely either.


I’ve been playing with the input volume in Audacity, along with changing the level on the mic itself. It seems like if I turn up the input volume any higher than 0.03 - 0.05, I start to get the hiss. This is even with the mic volume turned pretty low. The best levels I seem to get are with the mic volume at about 3/4 and the input volume at 0.03. But this leaves it pretty quiet, running about -20db - -18db. If I use Amplify, then the hiss is noticeable again.

I have two examples, one from the mic about 3/4:

One from the mic a little above 3/4:

Thanks again everyone.

From that experiment there isn’t a “sweet spot” where the hiss is lower :¬(

From those WAV files I just noticed your hiss noise is quantized , (only discrete amplitude values are permitted) …
Your hiss noise is quantized.png
The self-noise of a microphone isn’t like that : self-noise is thermal noise which isn’t quantized.

Some digital miss-match of bit-depth or sampling-rate between Audacity and the mic may explain your quantized hiss noise. Double check you have these settings in Audacity …®_G-Track_USB_Microphone

Bold emphasis is mine : of the preference options available a bit-depth miss-match seems like the prime-suspect to me.

I checked those settings, and they all match what you listed.

Reading up on quantized hiss noise now… looking on the bright side of things, this is giving me the impetus to learn a lot.

Thanks again for your continued assistance, it’s much appreciated.

The only remaining thing I can think of is an audio-driver [conflict?] problem …

If it is a due to audio-drivers, the quantized hiss problem will not be specific to Audacity,
e.g. will also occur on Windows built-in sound recorder.

I’m traveling this weekend and won’t have access to the laptop and mic until I return, so I’ll run through this when I get back.

Thanks for the info.

I tested recording using the Windows Sound Recorder. Here are links, wasn’t sure if it was best to leave it as the normal WMA the sound recorder generates, or to convert it.



This was with the mic level at 50%. It sounds to me like the hiss is still there, but I haven’t been able to figure out if it’s quanitized…

If it is, from what you said earlier Trebor it points to a driver problem. I’m using the USB Audio CODEC, which, if I understand that page you linked, is what I should be doing because it’s the default and not anything provided by Samson. But chances are high I’m misunderstanding something here…

Thanks again.

The hiss noise on that wma file doesn’t have the quantized appearance, ( it does sound loud though for a $100 mic ).

A minority of “Samson G-Track USB Condenser Microphone” buyers report a hiss-buzz, e.g. … Hissing sound...

and claim it’s a driver problem, ( e.g. a particular mic works OK on some computers, not on others ) …

Thanks for looking up that info. I haven’t noticed much change between the various computers I’ve tried it on. Normally use it on a Windows 7, which is what that poster says works well. But I’ve also tried it on another 7 machine (both are SP1), an XP SP2, and MAC OS 10, with not much difference. Maybe I just have a bad mic. Bummer that I bought it five years ago and only now thought to myself, “Hey, maybe I should try to track down the source of that hiss so that I don’t have to mess with the Noise Reduction”.

Guess I’ll be working through any tutorial info there is on the Noise Reduction, to make sure I’m really using it correctly.

Thanks again.

Been there – USB mics are not a good idea/they pick up all kinds of computer noise/computers were not designed for recording high quality, whether mic jack or USB route. It’s possible newer mics are better, and of course more expensive ones–BUT if you have money to spend, go with stand-alone stuff designed for recording music. For about a hundred you can get a Tascam portable music recorder. Then upload to the computer for editing/mastering, sharing/selling and becoming world famous. Cheapest highest quality route, IMO. I get better quality recording with my iPod (until I can get better equipment) then I did with a USB mic.