Asio device setup window

My setup is as follows:

  • Pentium E2140, 1GB ram, Windows XP SP3
  • Marian Marc 4 digi (4 analog I/O, 24/96)
    It was preety straightforward to compile Audacity 2.0.6 from SVN with ASIO, but I cant make Audacity to record from all 4 inputs of Marc4digi. Audacity recognizes only two first inputs and outputs, when other programs, like Sonar 6 LE which I also have, works with all 4 analog I/O.
    Other issue is that choosing ASIO as audio host, makes Audacity irresponsive for about 70 seconds.
    In audacity I can’t find “ASIO device setup”, whitch I can see in other DAW programs. This is where one can choose inputs and outputs to use, especialy more than first two.

I also tried my Audacity with ASIO build on other machine with Windows 7 and ESI Julia. It worked well with ASIO, without any freezing and I was able to record 4 tracks without any issue.

It seems like Audacity makes some kind of autodetection, which in my first setup above, fails after about minute. Could someone pease help me with my Audacity/ASIO/MARC4digi issue?


Audacity doesn’t have an ASIO Setup. Audacity can’t choose which inputs to use yet - you have to pick all of them and delete any unwanted tracks that you record.

How many recording channels are shown in Device Toolbar? Is there a “master” device you can choose which records all channels?

Can you post Help > Audio Device Info… from Audacity. Please see here for how to attach files: .

Have you installed the Marc 4 digi driver suite correctly?

Leaving aside higher latency, does Audacity see all four channels if you choose Windows DirectSound host?


No, there is no ‘master’ setting.
I can only choose: ‘MME’ or ‘ASIO’ as a Host.
When host is ‘MME’, Playback device can be:

  • Mapowanie dzwieku Microsoft - Output
  • Marc4-D Analog Playback 1-2
  • Marc4-D Analog Playback 3-4
  • Marc4-D Digital Playback
    Recording device can be:
  • Mapowanie dzwieku Microsoft - Input
  • Marc4-D Analog Record 1-2
  • Marc4-D Analog Record 3-4
  • Marc4-D DIgital Record

When host is ‘ASIO’, there is nothing more to choose:
Playback Device is only ‘ASIO Marc 4 Digi’,
Recording Device is only ‘ASIO Marc 4 Digi’.

Regardless of chosen host or device there are only: ‘1 (Mono)’ and ‘2 (Stereo)’ in channels.
Attached file: audacity-asio-marc4digi.txt contains all the text from Audio Device Info.

I’m sure that drivers are installed correctly, because other programs (Sonar6LE, RightMark Audio Analyzer 6.3.0) works well on this machine using ASIO.
There is also rmaa-asio.txt, containing ASIO properties from RightMark Audio Analyzer 6.3.0 after choosing all devices in Record and Playback device selection, in ASIO device setup of RMAA.

I can’t chose Windows DirectSound host because drivers doesn’t support it. Here is part of readme.txt from latest w2k/xp drivers

" ------------------------------------------
4. What’s to do

  • WDM Kernel implementation to support DirectSound
    and WDM based applications"

Audacity is only aplication I know, which freezes after choosing ALSA as Host, but I also checked other DAW using PortAudio - Traverso.
It behavies similary to Audacity - there are only two input channels in ALSA on Marc4Digi but with ESI Julia one can chose from all 4 imputs. So maybe there is something wrong between PortAudio and Marc4Digi?

rmaa-asio.txt (1.17 KB)
audacity-asio-marc4digi.txt (3.52 KB)

Thanks for your research.

The product home page says the driver suite includes DirectSound.

There is no way we can test with your equipment. Have you asked the opinion of the device manufacturer or asked PortAudio where exactly the technical problem lies?


No, I haven’t asket them yet, but it’s time to do so. I will let you know about any progress in my case.



Here is some kind of workaround to my Audacity vs ASIO vs Marian Marc 4 Digi problem (Konrad Jende from MARIAN GmbH - thank you :smiley: )
When application has “ASIO device setup” or “Asio control panel” and it’s able to chnage some settings of soundcard, driver eventually writes it all down in Windows Registry. So, I opened RMAA, checked 4 analog inputs and outputs to make proper settings for Audacity. After that I did a copy of RMAA registy entries and pasted it into Audacity part.
Originaly it looked like this:

[HKEY_CURRENT_USERSoftwaremarianASIOMARIAN Marc 4 DigiC:/audacity/Audacity.exe]

Now it looks like that:

[HKEY_CURRENT_USERSoftwaremarianASIOMARIAN Marc 4 DigiC:/audacity/Audacity.exe]
“40880000”=“Marc4-D Analog Record 1-2”
“40880100”=“Marc4-D Analog Record 3-4”
“40880200”="Marc4-D Digital Record "
“40880080”=“Marc4-D Analog Playback 1-2”
“40880180”=“Marc4-D Analog Playback 3-4”
“40880280”="Marc4-D Digital Playback "

Now almost all works well and I can record all 4 analog channels. There is still about 70 seconds of freezing, everytime Audacity starts with ASIO as a host but I will ask about it at PortAudio list.


Thanks for that.

Since Marian uses registry entries, I wonder where the fault lies that the wrong entry is written that has only two channels. I assume it is Audacity’s or PortAudio’s fault that it does not detect all four channels in the first place, so that may be something to ask PortAudio too.