Apple Effect Plug-in not Working in OS X 10.10 beta 2

Hello there!

Long time Audacity users, first time poster. I recently, in my over zealous Mac fandom, upgraded to the public beta of OS X 10.10. Today, when I tried to edit a project for the first time since downloading OS X 10.10, the Apple effects (e.g., Apple: AUMatrixReverb) no longer work. No error message or dialog box appears, it is just as if I did not even click on them. All of the other effects work just fine, but NONE of the Apple-specific effects are working. I have not moved any files or directories on my own that relate to my applications or libraries.

I record college radio shows via Audacity, and as the semester is starting, I am hoping to get those effects back up and running soon as I use them rather frequently. Anyway, this is my first time ever having a major problem with the software in the 2+ years I have used it. Any help from the forum community here which be greatly appreciated!

Thanks in advance,

Can you Time Machine your way back to 10.9?

It would have been better to put the Yosemite beta on a separate partition if you only have the one Mac.

Someone else has reported this in 2.0.6-alpha. What version of Audacity are you using? Please give all three numbers from Audacity > About Audacity… .

There is a small chance this might help, according to what that other person appears to be telling me. Reset Audacity Preferences thus.

  1. Quit Audacity
  2. Go > Go to Folder in Finder
  3. Type in:
/Library/Application Support/audacity/
  1. Open the “audacity.cfg” file in TextEdit
  2. Delete all the text and replace it with just this one line at the top:


Hi Gale,

I tried what you noted, but there is actually no Audacity folder in my Application Support!

As for the version, I am running 2.0.0. I did upgrade to 2.0.5 yesterday, but it wouldn’t even load for me. I kept getting an error about it not being able to find a certain library (yah, I should have written down exactly what the error was…). So, I used Time Machine to go back to 2.0.0. Perhaps all I need is the .cfg file?

So, I tried creating a text file, renamed it audacity.cfg and used that text command you noted, and placed it in /Library/Application Support/audacity. Still no luck…

Thanks, sorry for raising your hopes about audacity.cfg but the other person has confirmed also that resetting audacity.cfg does not help.

If you are sill using Yosemite, do Audio Units load in GarageBand or any other audio editor? If not, then I don’t think Audacity needs to be concerned. I don’t know what version of GarageBand comes with Yosemite, but here is how to load Audio Units in GarageBand 11: .

Are you sure it wasn’t an error about Critical Nyquist Files, due to running Audacity from the DMG:
Installation: Do NOT run Audacity from the DMG!!!! ?