Anything I import to audacity is empty! [SOLVED]

I started getting this problem some weeks ago. I can import audio files normally but when I do, they are blank/empty (idk the right word for it)
Here’s a gif to show it

I’m using audacity 2.1.0 on windows 8

On my machine, the GIF repeatedly loads and it’s really annoying.

You have silent files or the sound level is so low it doesn’t appear on the blue waves. If you play it, do the sound meters move? If they don’t, then there’s no show there.

Download this 39 second sound file I made and see if it plays.


nope, doesn’t play, same thing as with other ones.

Forgot to mention in my original post; even the ones that worked before don’t work anymore

Is the download 38 - 3/4 seconds long?

When was the last time you powered off the machine? Try that. Start and see if the problem is still there.


Check the location of the Audacity temp folder by looking in “Edit > Preferences > Directories”.
The temp folder must exist and must be writeable for your log-in. If necessary, select a new location for which you have read/write permission (and has plenty of free space).
The temp directory should be on a local internal drive.

I realized that’s the case instantly when I read that! You see, I managed to somehow mess my temp folder up a while ago and I think it got deleted or something (don’t ask how, my stupidness is sometimes on a whole new level)
I created a new temp folder for audacity and now it’s working again!

thanks for koz for trying to help too tho