Any way to increase native font/menu sizes?

Xubuntu 20.04
Audacity 2.3.3

I have some new 4K monitors. The fonts in the normal menu sections of Audacity controlled by the window manager are fine, but the text withing Audacity itself is very small. For example, Opening the Preferences or Edit Metadata Tags menus shows the internal text at a very small point size on these monitors. Is there any way to to make the size of this text larger?

Also, it appears that the window manager text is being displayed on the Audacity Device Toolbar. This text (e.g., “ALSA” and “Channel”) is too large for the size of the buttons and is being truncated both horizontally and vertically. Is there a way to increase the size of the toolbars along with the text size?


I also have this problem with Xubuntu.
There is a solution, but it may require changing display settings for other apps.

  1. Open “Settings > Appearance” from the Apps menu.

  2. Open the “Fonts” tab and de-select (remove the tick) from “Custom DPI settings”.

  3. Increase the sizes for “Default font” and “Default monospace font”



I really appreciate the reply. However, I unchecked the Custom DPI box and all the system fonts got very small. OK. Then I tried to increase the default font size and when I did, it completely blew up the xfce4 desktop/window manager! The screens (I have a dual monitor setup) went blank for 5 minutes and then logged me out. When I logged back in the scale of everything was blown up like I was on Windows with a 1990’s monitor. The screens were now mirrored rather than treated as two adjacent monitors and other things were off. I managed to reset the parameters back to the defaults and then when I tried to reboot, it instead logged me out again! I finally got the system to reboot and everything was pretty much back to normal. i guess I’ve found a major bug in the window manager! It may be an artifact of having an Nvidia GPU, but I’m not sure. So, no relief so far. :frowning:

I just came here because I have the same problem as the OP. I run Xubuntu on a Huawei Matebook 13" with 200ppi. The font is microscopic.

Unchecking the DPI setting and fiddeling with the font size is no option as it kills pretty much everything else, especially any web applications you might to run from your browser.

While googleing, I found this notion from 2012 on the forum saying that audacity is not DPI compliant.

So I guess the issue is known for at least 10 years. Any ideas why it has never been resolved? Is it low priority because there really are so few aspiring audacity users with high ppi monitors or is it actually difficult to fix.

Just raising my hand as a user of a high DPI monitor (3840 x 2160 - 4K “Ultra HD”).

I use KDE and have Display Configuration - Global Scale set to 150% and Fonts - Force Font DPI set to 144 which works well for all KDE apps and most GTK apps.

Audacity is usable - menus and dialogues are fine - but toolbar buttons are smaller than is comfortable, and fonts are too small in the recording device, playback device, timeline, selection timestamp and other widgets.