Any plugin from the LSPDA set causes a scan....

The stock plugins do not cause a scan. Only any of those included with the package. I made a fresh directory of Audacity - no scan. I copied just one plugin (plate verb) over from somewhere else, and it causes a scan.

I might think the plugins.cfg isn’t getting written to, but I don’t know what would be written in there, because a plugin name gives an error saying ‘should be =’. Um, okay.


Included with which package?

What is the full name of that file and where did it come from?

Where do you see that error?
What is the full error message?

If you mean then dll’s from that package will be scanned (and ignored) when Audacity scans for VST effects. On Windows, VST effects are dll’s, like the LADSPA plug-ins.

Audacity will scan for VST effects the first time you use it, then not again unless you ask for the rescan in Effects Preferences and restart Audacity.

LADSPA dll’s will be detected as soon as you put them in the Audacity “Plug-Ins” folder and restart Audacity (whether you rescan for VST effects or not).

Only VST plug-ins are added to plugins.cfg.


Hmmm, happens with legacy Audacity, too. I guess it’s this particular PC, because I get correct behavior on my main rig. I don’t know what’s different; though this one is a Gateway, and the other is a gigabyte mobo build, they’re both late model P4s with (the same version of) XP32.

We don’t know what happens, with what plug-ins package, because you did not answer Steve’s questions.

If this something happens without going into the Effects Preferences to rescan VST effects, can you post an image of the error message box you see (ALT + PrtScr, open Paint, Paste, save as a PNG flie, then attach the image to your message using “Upload attachment” underneath where you post messages).


Despite missing one letter in the acronym, I thought it was obvious which package, as I put it in the title. The package ya all have for download. Are there any others?

Second, there is no error message. It just scans every time. The scanning dialogue box shows up. Like if I manually selected it. But I didn’t. You know, this one.

There are hundreds of other LADSPA plug-ins.

By default the “set of over 90 LADSPA plug-ins” from the Audacity web site plug-ins page installs all 90+ plug-ins from the pack. It is not clear to me what you mean by, or how you achieved: “I copied just one plugin (plate verb) over from somewhere else”

Although you originally said:
“because a plugin name gives an error saying ‘should be =’.”

To be clear, are you now saying that you installed the aforementioned “set of over 90 LADSPA plug-ins” and now you see a scan (but no error message) each time you start Audacity?

So presumably you:

  • placed or installed Audacity in “DDocumentsAudacity”?
  • installed the LADSPA plug-ins in “DDocumentsAudacityPlug-Insothers” ?
  • moved “plate_1423.dll” from “DDocumentsAudacityPlug-Insothers” into “DDocumentsAudacityPlug-Ins” so as to use it?

Do you have any VST plug-ins? If not, there is an issue that Audacity may scan for VST’s every time without this being asked for in Preferences. That scan is recursive, so looks in folders inside the Audacity “Plug-Ins” folder and so will scan all your LADSPA plug-ins in “others”.

To stop the VST scanning at each launch, you will need to quit Audacity, then find audacity.cfg as per these instructions: .

Note in those instructions that you may have to tell Windows to show hidden files and folders.

Then open audacity.cfg in Notepad. Look for:


If {VST] doesn’t exist, add that line.

Underneath that [VST] line, add:


Save audacity.cfg. Audacity should not scan now. Alternatively, put a VST plug-in in the Audacity “Plug-Ins” folder.


Oh. Yeah, I use Documents/My Documents as a general nexus. I read earlier threads on the scanning issue. I have no VST plugins; I thought the LSPDA ones were VST, so yeah I have none. I know about cfg and ini files, and some basic command line, via MAME. I should’ve put together that I needed to add to the VST line in the cfg and what the command was.

Here’s the line, with added entry.


It’s not obeying, though. I’ll just disable them. Thanks.

If you don’t use VST or LADSPA plug-ins then you may as well disable them. You don’t need to manually edit the audacity.cfg file to do that, you can do it through the graphical interface: Edit menu > Preferences > Effects". The built-in Audacity effects will still be available.

I have the LADSPA (got it right this time!) plug-ins. I have no VST plug-ins. I did disable them via the ui. For curiosity’s sake, I checked my other computer, which far as I know has no VSTs either, and its cfg had no “Rescan=0” entry. Yet it doesn’t rescan every loading. Doon’t knoow.

Anyways, thanks.

Possibly it has a VST plug-in somewhere on the system - you could check to see if plugins.cfg is empty or not. If it is empty, then either the scan is not happening, or it is happening so fast that you don’t see it - which is possible if Audacity only has the shipped DLL files it came with.


This is interesting. There are entries in the ini - but none of those exist in the plug-ins folder. Either way, it’s the same I guess.

You can check in plugins.cfg what the path to those plug-ins is. If the plug-ins are moved or deleted, plugins.cfg does not get updated until rescan.