AirPods Pro and Audacity


Normally while editing audio I use the output from my R0decaster Pro and wear a set of head phones. Today I got a wild hair and thought, “Hey why not use my Airpods to edit?” Something new to do. So I put my Airpods on and ran a quick test. I recorded my myself and listened back. It worked just fine. Next I loaded in the file that I wanted to edit and for some reason the audio would not play. The cursor was moving very slowly and when it hit audio no sound. I loaded up my music player and tested the sound. Everything was fine there. I deleted the track I was working on and reran the audio test I did earlier. Everything worked. I have no clue as to why. I turned on the audio interface, loaded up audacity, and loaded up my editing project again. No problems.

Question: Can you not edit files while using blue tooth headphones or specifically Airpods?

My Set up: MacOs Monterey 12.3, Audacity 3.1.3, Airpod Pro latest firmware. The file was a large WAV file about and hour and a half in length 44.1k, 16bit.

I look forward to any questions or Comments

Best Regards,


Audacity is known to not play well with bluetooth headphones. Apparently it may have something to do with the bluetooth protocols where the headphones can momentarily disconnect. This doesn’t seem to bother other audio programs (such as Apple Music/iTunes) but breaks Audacity’s connection to the headphones.
– Bill