Air pods not syncing with audacity HELP

So I was in a coffee shop today and I just wanted to work on my audacity recordings with my new iphone air pods. However, when I went to listen, my air pods would not connect to my audacity recordings. I tried everything I could, but there was not even an option for me to choose my air pods as a out put source. Can you please help me? The air pods have no problem connecting to my iphone, and to my macbook pro and itunes and they were a gift. I would like to be able to use them as well as keep other strangers in the coffee shop from listening to my recordings. Please help. I feel like technology doesnt like me : (

They mount as a bluetooth device, right? Can you see them in Mac System Preferences?

Apple (upper left) > System Preferences > Sound.

Put them in, connect them, make sure they work and then Start Audacity. Look for them in the Audacity Device Toolbar.

Audacity checks for devices when it starts. You can also Transport > Rescan…

They could be sticky because they’re both earphones and microphone, right? I don’t know how the Mac deals with that. Being wireless could be messy, too. I don’t know how the Mac deals with a ratty connection.


Yes I can see them in the sound system on my computer and connect them, but when I start audacity, they are no there and there are no drop down options for them. So you think there is no way for audacity to connect?

Audacity doesn’t support bluetooth all that well. And you might have an old version of Audacity - you didn’t give your version. See the pink panel at the top of the page.


I have 2.1.2 and a macbook pro 2013 with op system macOS Sierra 10.12.3

I am having the same issue. I find that Adobe Audition works - my AirPods show up as an option on the output devices there. But in Audacity this bluetooth device doesn’t show up as an option and choosing “built-in output” doesn’t work. I’m using the most recent version of MacOS with Audacity 2.1.1.

Please put numbers to the most recent version of macOS, for complete clarity. 10.12.3 ?


Does it help, each time before launching Audacity, to go to System Sound Preferences and reselect AirPods as default output device (even if already selected)?


no it still didn’t do anything by selecting air pods

Any update on this? I’m suffering from the same problem

Which version of Audacity are you using?
Have you set the Air Pods as the default output device in “System Preferences > Sound”?
What have you set as the output device in the device toolbar?

Have you set the Air Pods as the default output device in “System Preferences > Sound”?

We’re not suggesting you do that forever (although it is a good desperation method), but more to find out if that action fixes the problem every time. That gives the developers something to chew on.

There’s nothing quite like a problem we can’t replicate. Nobody can fix it if it’s not broken.


Hi, I’m on Max OSX 10.12.6 and have the same issue. Has any fix been found for this?

Which version of Audacity?
Have you selected the Air Pods as the playback device in the device toolbar?

Hi - thank you for the reply. It is Audacity 2.2.2. The AirPods don’t appear as an option. There is something called “AirBeamTV”

Okay, saw no one had posted in years about this, but my AirPods weren’t syncing with Audacity either and it was driving me nuts (I was trying to edit 8D audio, which requires headphones).

What worked for me was - saving my work in audacity, quitting audacity, connecting my AirPods via Bluetooth and then restarting audacity. Audacity only looks for audio devices when it is first launched, unless you specifically tell it to look again.

For another post on the forum: While Audacity is open, you can click on “Transport menu > Rescan audio devices”. You will need to “rescan” (or restart Audacity) whenever you attach or remove an audio device. Note: this didn’t work for me, only the above worked for me. Hope this helps!

I just got some AirPods and was trying them out with various apps and devices. When I tried listening to a file in Audacity, I ran into the no sound issue in this thread. I tried the suggestions I saw (restart Audacity, rescan devices) but they didn’t work for me.

Here’s what worked:
With the AirPods on/in your ears, go to Preferences > Devices > Playback, then choose your AirPods.

Now audio played (yay!) but with loads of crackle noise (waah!). So I looked in the forum and saw the buffer length comments. Again in Preferences > Devices > Playback I increased buffer length to 400ms. Worked like a charm.

I’ll still use a wired headset most of the time with Audacity but it’s good to have the option for quick listening.

(Audacity 2.4.1. 2015 MacBook Pro running Catalina)

1 Like

To fix this:

  1. Quit Audacity

  2. Click on the Bluetooth icon in the upper right corner of your Mac computer screen.

  3. Select AirPods - make sure the AirPods are in your ears so they’re on and you hear the connecting beep.

  4. Go back to Audacity, open the app, and choose AirPods in the dropdown selector.

That should do it.

How do you turn AirPods off? They are battery operated, right, and not that big a battery, either?

Is there such a thing as having them Power Down while they’re in your ear? It would be very Apple to build-in a power save feature.

What is the indication that the battery(s) are flat?

You know all this is going to come up, because if a device loses contact with the computer, however briefly, it vanishes forever and has to be reconnected to Audacity. This could also be a problem if you have a ratty BlueTooth connection. There can’t be ratty anything. I think this is a similar problem that Audacity has with Internet Storage.


Continuing the discussion from Air pods not syncing with audacity HELP:

This bothered me for so long. THANK YOU!! <3 <3 <3