Adding Rhythm Track inserts it in front of first track instead of with it

I sampled a recording, pasted it into a new project. I’m now trying to add a Rhythm track just to use as a metronome for other things I’m trying to add. It inserts it before the sample, not along with it. Why?
Rhythm Track.png

In “Tracks” menu, turn off “Sync Lock”.

That did it. Thank you!

Why would Sync-Lock do that? I know about marrying a label track to a music track. What’s it trying to lock in this case?


I agree that it looks rather weird. I think it is synchronising the end of the selection in the new track with the start of the audio clip in the first track.

It looks less weird in this example (which is doing exactly the same):

  1. Start with two clips in one track, and an empty track below.

  2. Place the cursor at the boundary between the two clips, but in the second track, like this:

  3. Ensure that Sync-Lock is enabled.

  4. Generate a new sound into the second track: