Add silence does not work

I have a 2h mp3 track that I imported to Audacity and I just want to add 5h of silence before the mp3 track starts.

To do so, I selected the beginning of the track and added 5h of silence via Generate > Silence. It all looks good but when I export the entire mp3 and play it, the silence seems to end much earlier than the 5h.

The exported mp3 has much less silence (around 2h45) than the expected 5h … what is going on?

Possibly Edit > Preferences > Import/Export > Ignore blank space at the beginning

that option is unchecked

How do you"play" it? It worked fine for me in Audacity…

I export it in mp3 and the play it in VLC (macOS)

I’ve just tried again with a 1h silence + 1h of my original sound (which is a hairdryer sound) and the same occurs. The hairdryer starts playing after 27min and not 1h as expected.

Here is the export “1h silence + 1h sound” mp3.

EDIT: Now I see that the playing the mp3 in Chrome works as expected. Could it be that some other software report the playtime incorrectly?

Yes. So I am able to duplicate this issue. On VLC, the file plays as approx 30 minutes of silence and 1:30 of hair dryer. So there seems to be a bug somewhere in VLC.

Microsoft Media player does something similar, so perhaps they are using the same MP3 decoders. However, MSMP crashed, rather than spitting out an error message so there seems to be a bug there.

Foobar2000 and Power Media Player do the the same thing as Audacity. So this gets Audacity off the hook. I am not sure what else to add, if anything. :neutral_face:

Are you using variable bit rate encoding? If so, try constant bit rate.

Are you using variable bit rate encoding? If so, try constant bit rate.

I was using the default Standard, 170-210 Kbps setting . I’ve just tried with a fixed 190 Kbps and it seem to be working as expected now.

I’ll confirm later

yes I can confirm that the fixed bitrate fixed the issue. Thanks for your help!

This topic was automatically closed after 30 days. New replies are no longer allowed.