Add rhythm track to existing project

Hi, Is there a way to add a rhythm track to an existing project? I originally used an external click track so i know the exact BPM. I’ve tried generating a rhythm track but it is being placed at the front of track 1 instead of alongside as a new track. Thanks.

  1. Click on a track where you want the first beat to occur.
  2. Press “Enter” to toggle off the track selection (de-select the track that you clicked)
  3. “Generate menu > Rhythm Track”

Thank you for that Steve. I followed it and it created the new click track but not alongside the existing song. The existing wave bars were pushed along so that the new click track played alone. when it ended the existing track resumed where I had started the new one. I could use the Time Shift Tool, Is that the way? Thanks.

Sounds like you missed out step 2.

Hi Steve, No i followed all the steps, and it did toggle off the selected track and created a new track. However on playback it starts without the new click track until it reaches the point i chose then plays the new click track alone. At the end it reverts back to playing the original recording minus the new click.
However I have found another way, Create a new click track. open existing project (opens in new window). Then cut and paste one into the other. Seemed to work OK.

Hmm… OK, so try this:

  1. Tracks > Add New > Mono Track
  2. Click in newly created mono track where you want 1st beat.
  3. Generate > Rhythm Track, etc.

I hope this helps. :smiley:

Thanks Jademan but same result. It punches a hole in the original track when i tried it. Did it work for you?

Which exact version of Audacity are you using? (look in “Help menu > About Audacity”)
Which version of Windows?

Perfectly. (Also, added additional clarity to original post) :smiley:

Steve, apologies for delay, I’m using Audacity 2.4.2, windows 10 pro.

These steps should work: Add rhythm track to existing project - #2 by steve

If not, do: “Tools menu > Reset Configuration” first, and then try again.

Success! Thank you Steve, reset configuration worked. Many thanks. :smiley: