ACX check Plug-in won't open in Audacity

Hello all!

I have read the numerous posts about ACX check plug-in and how, after being downloaded, it won’t appear in the audacity “add/remove plug ins” list.

I have followed every one of the threads. I have tried multiple solutions.

I’m currently on a MacBook Pro with OS X El Capitan 10.11.6 I have Audacity version 2.1.2

Upon trying to fix the problem myself, I noticed that when I was trying to locate my “plug-ins” folder in finder, I couldn’t find any folders in Audacity. I then read in another thread about how you have to drag the entire audacity folder into applications to find the folders. I then added the ACX Check.ny file into my Plug-ins folder…still no luck.

I also see that all of the plug-ins listed in the “plug ins” folder are not under my “effects” menu in audacity. This seems to be all of the nyquist plug-ins. I also checked my preferences, and the nyquist box was checked, so that’s not an issue either.

I also went into terminal and tried to allow the plug-ins because Gatekeeper won’t allow them sometimes since they are from the internet. But no…under terminal, after I copied and pasted: sudo xattr -r -d /Applications/Audacity/
Terminal says, that file was not found.

So, now I’m completely confused and don’t know how to get ACX Check to work. I have tried every solution, and none of it seems to work. Any help??

The instructions you are reading about sudo xattr should only be needed in Sierra 10.12.1 and higher.

Anyway I suggest you drag your Audacity folder to Trash and install the new Audacity 2.1.3. That version is codesigned with an Apple Developer certificate which should always allow Audacity to launch with the shipped plugins present.

Follow these steps:

  • Double-click the downloaded 2.1.3 DMG to mount it.
  • Drag the “” icon in the DMG window to the /Applications folder icon on the right. Alternatively, drag the “” icon to any other location of your choosing.
  • Do not double-click the “Audacity” icon in the DMG to launch Audacity from there.
  • Eject the DMG at bottom left of Finder, then launch from /Applications or from your chosen location.

2.1.3 is now a self-contained application without its own folder, so it is easier to put ACX Check in ~/Library/Application Support/audacity/Plug-Ins.