ACX Check not working

I have followed all the directions online for using ACX Check and can’t seem to find it in Audacity.

I am using Audacity 2.2.1 with MacOS High Sierra Version 10.13.2

The link on the wiki page led me to download Acx-check.ny.txt.

On the computer I have dropped this into:
Library>Application Support>audacity>plug-ins

Then I go to Audacity:
Add/Remove Plug-ins…

But do not see ACX Check anywhere. I am very confused because all of the directions on multiple sites say this is how you do it. At my wits end. I’m already in the process of creating my first audiobook and am worried all the work will be denied by ACX if this isn’t fixed. Thanks for any help.

The link on the wiki page led me to download Acx-check.ny.txt.

Can you point me to that link?

The download is a Nyquist Program not a plain text file. Remove the .txt from the end of the file and try again.

Also, It appears under Analyze in Audacity, not Effect.

Only the first three analysis lines and sentence 2/3 down are used in ACX submissions and it’s highly recommended you do your work in Mono (one blue wave) instead of Stereo.

Everybody fails Noise and Noise Reduction is not always the answer. ACX has a failure they call Overprocessing where you passed ACX Check by appying too many effects. The goal is to sound natural.


This is what a successful ACX Check panel looks like.

If your submission fails, the panel will give you simple comments about the failure.

You can confuse the app. ACX Check looks for at least 1/2 second of clean Room Tone to measure noise. If it doesn’t find any, it takes the closest it can get and very likely fail you even though the performance may actually be OK.

Room Tone is what the room sounds like when you stop talking. Do Not make mouth noises or shuffle in your seat or make other unconscious noises. They will all fail a noise test. I tell people freeze and hold your breath for about a second.

ACX requires portions of Room Tone in your submissions, so you will need to get good at this no matter what else happens.


Yes, I have gone to “Analyze” to add the plug-in. It’s not there.

Both of these links send you to a .txt file, not a .ny file.

I have tried deleting the .txt from the end of the files and it just comes back.

Does anyone have a link that will work?

Fascinating. It’s been something of a mystery where that .txt thing is coming from.


See if that changes into a .txt file when you manage it.

I have a 10.11 Mac I can see what happens to me.

Acx-check.ny (9.33 KB)

kozikowski, you’re the best :slight_smile: That attachment worked perfectly.

Now I just need to figure out how to fix the issues that aren’t a passing grade.

Now I just need to figure out how to fix the issues that aren’t a passing grade.

Or, you can post a simple sound test and let us help.

Record it, export and post it. Don’t help.


Now we need to do two things at once. I just downloaded the Acx-check.ny plugin to my desktop and it arrived in good working order. OS-X 10.11.6 El Capitan
Screen Shot 2018-01-21 at 10.50.28.png
Where do you download things to?


Were you using Safari browser?


Yes I was using Safari. I’m guessing that’s the problem?

I think I got it. Safari automatically adds .txt to the filename. Right-click or Control-Click the file > Get INFO. Delete .txt in the filename box. Say it’s OK. Close INFO.

You may need this if you use any of the other audiobook tools, filters, and add-ons we supply.


It may be possible to fix this forever. I don’t know yet.

You’re a hero. You’re the first person to have the error consistently and stuck around for us to resolve it.



When you post the test sound file, give us a brief list of how you’re recording. What microphone, which interface if any , etc.

Which coffee.


Tears of joy. ACX check is finally working. Thank you so much for posting this because I’ve been going through the same thing for the 3 hours with the ACX Check.txt extension. I thought I was going crazy. Happy recording!

I thought I was going crazy.

You might be, but not for this reason.

ACX Check has one known, not-obvious problem. It finds the quietest half-second of performance and uses that for the “background noise” reading. So there has to be a quiet segment for it to find.

Somewhere in the performance, freeze and hold your breath for a second or so. Do Not Move. The software can hear your clothing moving and any breath sounds you’re making.

You will need those quiet segments if you’re reading for audiobooks anyway. ACX builds quiet segments into the submission requirement.


I have a Mac OS Sierra and am using 2.2.1 Audacity and I cannot download ACX check it says “There is no appliation set to open the document ‘Acx-check.ny’” . I tried to use audacity to import and it said Audacity doesn’t recognize try installing ffmpeg

Never mind I got it by by saving I’m lame library and watching Krystal Washer’s video

“There is no appliation set to open the document ‘Acx-check.ny’”

Correct. You have to be careful not to double click it or do anything else to suggest you want to launch it. Your job is to get it in the right folder so Audacity can get to it. Also as above, make sure your system doesn’t try to change the filename.


I am also using Safari. I have High Sierra, 10.13.2 and Audacity 2.2.1. I just downloaded the file that kozikowski provided and that worked just fine. I had also removed the .txt from the previously downloaded Acx-Check file which continued to fail to Enable. Thank you kozikowski!