ACX check not working Audacity 3 MacOS 10.13

Hello - so, ACX check worked fine with my latest version of Audacity (3.0) until right now - Now it runs, but I don’t see a screen with the ACX report anywhere - on a deadline! for book narration, please help!

You need to update to Audacity 3.0.2

You don’t need ACX Check. You can measure your work with ACX Audio Lab

… and you can use the older Audacity legacy tools like this.

Yes, it’s a lot more work which is why ACX Check was such a big deal. But you’re not drop-dead stuck.


Be aware of what that does and does not test.

It does check the peak and RMS levels, though it does not detect if the audio is too compressed.
It does check the file format (which ACX-Check.ny cannot check).
It does NOT check the noise floor (which ACX-Check.ny does check).

Thanks so much!

I have version 3.0.2 so will explore the other suggested options…it’s just odd because it was working just fine then stopped.


Using Audacity is always an education! the legacy tools look interesting :smiley:

In that case you have probably got the old version of ACX-Check.
The current version is here:

it was working just fine then stopped.

Did your Mac go through an update in the middle there? There is a fuzzy, soft recommendation that you make your machine notify you of an update instead of quietly doing it in the background. Windows machines are famous for this—sometimes forcing an update in the middle of an edit session. That can cause “it just stopped working.” The down side of that is the update rushed out to defend against a rampant and immediate virus attack.

Welcome to owning a computer. I do as much work as possible with the network disconnected. Yes, I’m the one.

I know this is computer folklore, but when was the last time you shut down your Mac? I don’t mean Restart, I mean Apple > Shutdown… and go make coffee. Do Not make it Re-Open Windows when you start it back up. We’re trying to avoid the baggage and possible damage of what you were doing when you shut it down.

That ACX Desperation Method uses some second-hand features of ordinary tools to do the work. Effect > Amplify will always try to push the volume of whatever is on the timeline up to Maximum (0, the bottom number). Therefore, the boost needed to get it there (the top number) is the current peak value. You just need to write it down and add the “-” sign to the front.

Analyze > Contrast is one of the only tools that works in Loudness (RMS). It will tell you the loudness value of whatever you select. If you select the whole chapter, it will tell you the RMS of the chapter. If you select some of the Background Sound “Room Tone,” it will tell you the audiobook Noise. Those are the three values that ACX-Check tells you.

Noise is the evil gremlin. Noise kills more home recording artists than anything else. It’s hard to explain what noise is because nobody can hear it. My grandparents owned a boarding house in the mountains. It really was dead quiet at night and none of the New York City people could sleep without the constant pounding of city noises.

Clean background sound is built into the audiobook chapter specification.

Screen Shot 2021-05-24 at 7.41.23 AM.png

In that case you have probably got the old version of ACX-Check.

The legacy ACX Check wouldn’t work on very long productions.


Howdy again, and thanks :slight_smile: Somehow ACX Check is working again, hooray!

I do have a quick question about RMS though, it’s at -17.7 and needs to be between the magic -18 and -23 db. Just a little snippet of a piece, the About section, and giving me so much trouble! I’ve edited it but then got this wonky RMS message. Have tried adjusting the Compression ratio, from 19 to 6 to 24 (up and down the slider) but no luck. I think this is a bonehead question but I’m stuck and would love a quick(er) answer.

And no, I have turned off my Macbook Pro in a LONG time…

thanks again,

foreground and background measure -17.97 using analyze contrast tool so close!!! :unamused:

Well, I selected the clip, turning the amplify level down -.5 and then the RMS came out OK (-18.1) Amazing!


But not close enough. Did you use the Mastering System? That puts both the Peak and RMS (Loudness) in perfect settings. -20dB for RMS and -3.5dB for peaks. Every time. Never miss.

The only variable after that is Noise.

Did you Export the original RAW reading as a WAV (Microsoft) 16-bit sound file? It’s a New User mistake to make corrections and jam them into the original reading without saving a clean backup. That means if you have a horrible accident, you can’t step back and try it again. It’s get out the microphone and read it again.

There is a shortcut that allows you to apply all of the Audiobook Mastering steps in one pass. Do you want to try that?
This is the Audiobook Mastering Macro. A Macro is a file whose job it is to run other files.

Audiobook-Mastering-Macro.txt (498 Bytes)
Download that file. Install it in Audacity 3.0.2 like this. Tools > Macros… > Import. Point it at this new file > Close.

Select your reading > Tools > Apply Macro > click on Audiobook Mastering.

Screen Shot 2021-05-24 at 1.33.38 PM.png
You should be able to see the blue waves change a little as the performance settles in to standards.

It should sound OK, too.

Did you get ACX-Check to work? What does it say the noise is?


and now ACX Check is not working again…

thank you thank you thank you! I will try this right away (audiobook mastering macro)
I don’t save .wav files yet - but should ??? I always save the original in audacity and edit the copy, though.
Will let you know how it works :wink:

Audacity doesn’t save sound files. It only saves works in its own internal Project format. That’s not all terrible, it will save timelines, settings, layouts, and sounds. So if you know you’re going to pick up a complicated edit later, this is a good way to go.

As long as you don’t need UNDO. Projects don’t save UNDO.

Projects are also not particularly bulletproof. Count the forum posts from people whose Projects won’t open.

When you get finished announcing a chapter or segment of your show, File > Export a WAV (Microsoft) 16-bit copy of the work. Mistakes, fluffs, errors, mis-speaks and all. Save that and move it into a safe place where you’re not likely to step on it or record over it by accident.

Then do whatever else you want.

You do this at the other end, as well. Your finished, polished, corrected edit master chapter is a WAV. Then Export the MP3 that ACX wants for publication. Once you Export the MP3, you can’t open it and change it. The only way to make a corrected MP3 is change the WAV and export that as the new MP3.

Never go production in MP3. It’s an evil time bomb.