For some weeks ago I had to change my motherboard. Before that I had Audacity 3.0.0 and everything worked fine. But after the motherboard change and the (old) system resetup (and working in every aspect except for Audacity) I discoved that Audacity didn’t work with WASAPI during playback. The motherboard change did mean that the soundchip in use also was changed. I don’t now which audio chip other than that Asus sais it is “ROG SupremeFX8-Channel High Definition Audio CODEC S1220A” on there website.

Audacity does record loopback with WASAPI and I can play it, if I change to Windows DirectSound or MME during playback. But if I try to playback the recording or anything elses with WASAPI activated I get an error message saying:
“Error opening sound device. Try changing the audio host, playback device and the project sample rate.”

I’ve updated Audacity to 3.1.3 and while doing so I also discovered an very old Audacity install (version 2.1.something). I tried to uninstall it and the folders in “Program Files(x86)” did disapear, but not the icon in “uninstall programs”. Don’t think that has anything to do with this sence it worked before, but it’s worth mention it anyway. I even uninstalled everything that I could find that had anything with Audacity, but the problem remaind.

To sum up:
I can record loopback with WASAPI.
I can’t playback with WASAPI.
I can playback with MME or Windows DirectSound

That sounds like a driver problem, but I assume you downloaded new drivers?

Checked that and found that I have the second latest driver, but it seems like it’s almost impossible to get the new driver from Asus or Realtek without the motherboards serial number and to see if I have that I need to remove my motherboard again, since Asus eventually placed it in the back… I dont have the box for the motherboard anymore. :frowning: But thanks anyway and I will see when I get the time to remove my motherboard to get the serial number.