A strange recording problem

A week ago: Use Audacity to record something, no problem with recording

Right now: No setting changes, trying to record something else… Recording doesn’t work.

Let me try to explain the best I can: Previously the recording worked just fine, no problems what so ever outside of the initial setup with the settings when I launched the program the very first time. And now all of a sudden the recording ceases to record.

Let me try and illustrate the best I can with screenshots:


In this image, it is set to record (The options for audio are grayed out) and yet, the progress slider does not move. It has been like that for a few minutes now and nothing has been recorded.

Even weirder is that it looks like it does do some recording progress… Only when I move the selection bar to the right, at which point it immediately jumps forward but it is still very much an empty file.


I figured that I might need to update the program, but even updating it from 2.2 to 2.4 I still have the same thing happen to me. I doubt it’s a driver fault, given that it still worked even after a Driver update or when they were out of date, so… I am a bit stumped.

Any ideas as to what might be the problem?

The current version is 2.4.2. This version fixes some important bugs in 2.4.0 / 2.4.1.

It is set to record from “Yeti (loopback)” in the Device Toolbar.
The recording device needs to be set to whichever device is being used for playback (I’m guessing that’s your “Phillips SHG7980”).

I didn’t specify the entire line. Basically I made a fresh update to the program.

Even if the setting was incorrect, the problem isn’t “My recording isn’t picking up sound”, the problem is “My recording doesn’t even progress nor record”. Let me put it like this: You see the difference between the two screenshots, how one looks like it hasn’t started yet, while the second one looks like it recorded seven seconds of audio?

The first one stayed like that for over a minute, and the second one I had to move the selection bar to a point, then it immediately appeared as recorded up to that point.

And the files are still empty and cannot be played.

My recording doesn’t even progress nor record".

That’s because you’ve selected “loopback” which is for streaming/playing audio and there is no digital audio stream going into the Yeti. Assuming you want to record from the Yeti, select it without loopback.

… Huh. Now I feel like an idiot. Though now my big question is how did it get set to loopback.

Anyway, things are sorted now and things seem to be working as intended. Thanks!