A problem importing files

Dear all,
I downloaded and compiled both audacity 1.3.9 and wxwidgets 2.8.10. Everything seems to be ok, but when I run the program and I import an audio file (it doesn’t matter if it’s wav or mp3) I immediately get an assert error.
For example if I try to import a wav file and I debug, I can see that the line that asserts is the following:

while the call stack is the following:
msvcr90d.dll!_get_osfhandle(int fh=3) Riga 315
Audacity.exe!psf_set_file(sf_private_tag * psf=0x03719858, int fd=3) Riga 862 + 0xc byte
Audacity.exe!sf_open_fd(int fd=3, int mode=16, SF_INFO * sfinfo=0x01d5ecb0, int close_desc=1) Riga 343 + 0xd byte
Audacity.exe!PCMImportPlugin::Open(wxString filename={…}) Riga 135 + 0x20 byte
Audacity.exe!Importer::Import(wxString fName={…}, TrackFactory * trackFactory=0x036f9fe8, Track * * * tracks=0x01d5f41c, Tags * tags=0x03707008, wxString & errorMessage={…}) Riga 176 + 0x35 byte
Audacity.exe!AudacityProject::Import(wxString fileName={…}, WaveTrackArray * pTrackArray=0x00000000) Riga 3159 + 0x5f byte
Audacity.exe!AudacityProject::OnImport() Riga 4343

Please note that I get the same error also in unicode.
Many thanks in advance for your help!

P.S. I’ve just found that I get the same error when playing audio just after having recorded it from microphone.
P.P.S. The unicode version of audacity that comes with the installer doesn’t have this problem

Problem solved!

I unadvertedly compiled wxWidgets with visual studio 2005!
Compiling it with visual studio 2008 has solved the problem.

Many thanks to those that took the time for reading my previous post.

<<<I downloaded and compiled both audacity 1.3.9>>>

What is this “compiling” thing of which you speak? You’d probably get significantly fewer blank looks had you posted in the “Compiling Audacity” section of the forum.



p.s. Yes I know what a compiler is…

Thank you for the suggestion. Sorry for posting in the wrong section…
Maybe some admin could move this thread there…

All the best wishes!