"-9999 Unanticipated Host Error" - No Solutions Work!

Please help! I am using Audacity 3.0.0.

My Zoom H2n USB microphone is no longer working with my Audacity. I have looked through all the “solved” topics and none of them have worked. Not the Security allowing desktop programs to use mic, not anitvirus. I used to have a workaround involving starting Waveform 11 that let the device work after that, but this update to 3.0.0 of Audacity has removed that.

I have already uninstalled and reinstalled Audacity as well.

Any help would be appreciated.


OK, on my Windows 10 machine,

  1. Exit Audacity.
  2. Turn OFF Zoom H2n, and uplug power supply.
  3. Unplug USB cable.
  4. Open Audacity 3.0.0. Click OK at startup screen.
  5. Connect USB cable between H2n and PC.
  6. H2n screen illuminates to “SD CARD READER”
  7. with H2n PLAY button, advance down to “AUDIO I/F”
  8. Depress H2n PLAY button to select “AUDIO I/F”
  9. H2n displays “SAMPLING FREQUENCY” is 44.1kHz
  10. with PLAY button, advance to and select “CONNECT”
  11. On Audacity, note that Project Rate (Hz) in lower left-hand corner is 44100.
  12. On Audacity, Transport > Rescan Audio Devices
  13. On Audacity’s Device Toolbar, select MME, Microphone (H2n), Stereo, Speaker
  14. Press Audacity’s RED record button and note that stereo track begins recording audio.
  15. Stop Recording, Ctrl+Z to delete recording
  16. On Audacity’s Device Toolbar, select Windows DirectSound, Microphone (H2n), Stereo, Speaker
  17. Press Audacity’s RED record button and note that stereo track begins recording audio.
  18. Stop Recording, Ctrl+Z to delete recording
  19. On Audacity’s Device Toolbar, select Windows WASAPI, Microphone (H2n), Stereo, Speaker
  20. Press Audacity’s RED record button and note that stereo track begins recording audio.
  21. Stop Recording
  22. Press Audacity’s GREEN play button and listen to most recent recording

I hope this helps. :smiley:


I have the same problem although the circumstances are slightly different.

I have just bought an A-T LP120USB and ‘think’ I have done everything that I could find in the help section. Audacity recognises the unit as LINE USB AUDIO CODEC and my laptop is happy to play the vinyl through either the built-in speakers, or through a bluetooth connected amp. However whatever settings I have tried i either get the -9999 or -9996 errors. I only have the option of 48000hz /16 or 24 bit on the Realtec Hi Def Audio so have tried setting Audacity to 48000hz (as per setting up) with no luck. I have tried various combinations of settings but the same result every time. Considering I only bought the turntable to digitize my vinyl this is a bit annoying. Any help would be greatly appreciated.

ps windows 10 /audacity v3.0.0

Audacity comes defaulted to [X] Overdub selected. That means the instant you try to record something, Audacity will try to Play to your device. Obviously with a turntable, that will not work so well.

Audacity > Edit > Preferences > Recording > [_] Overdub (de-select) > OK.


Thanks for that reply. I had already deselected the overdub, Audacity will not play either… After my previous post I reset all windows sound settings to default and uninstalled and reinstalled Audacity… now I cannot get any sound out of the turntable at all. As it is the only response from Audacity is that it recognises the turntable when it is plugged into the laptop ( Rescan audio devices allows LINE USB to appear in the input choice box ) the option disappears then the turntable is unplugged (Rescan removes the LINE USB option). This is the same response that I get from Windows. Back to square one with the addition of a headache !

the only response from Audacity is that it recognises the turntable when it is plugged into the laptop

You can leave Audacity closed. Audacity gets its sound from Windows. If you’re in the Windows sound control panels and there is no jumping icon or sound meter when you play something, then that’s the end of the world.

Did you save your papers?


it appears to be the end of the world then! Windows can be such a pain! I suppose I will just have to try find a way around this or send the turntable back.

If anyone is interested, I found a solution to this issue.

Instead of plugging the USB into the laptop (which has no stereo analogue input) I fished out an old creative soundblaster 5.1 external unit ( silver with two thumbwheel controls on top) that had been kicking around in a box of bits for around 20 years… I connected the turntable line out to this and then connected the soundblaster to the laptop. It worked first time without any installation or settings to mess around with.

Thanks for the update.

For anyone else reading - from the manual Error opening sound device - Audacity Manual

-9999 Unanticipated host error: > this means means “something is wrong”. And appears to most often be due to either:

  • A lost connection to a USB audio device.

This can occur for a multitude of reasons, including:

  • badly fitting USB plug,
  • corrosion dirt or grease on the USB contacts,
  • high CPU use,
  • USB audio driver bug,
  • damaged USB cable,
  • faulty USB chip in the connected device
  • other

Most likely is a problem with the USB cable or connectors, but it could be something else.