50% default envelope on recording

I just launched audacity for the first time on an ubuntu studio 12.4 machine. When I hit “Record” it seems to apply an envelope to the recording, so that anything above the .5 clips. Is this a preference that I can adjust. I can use the envelope tool to remove this after-the-fact, but the clipping is just magnified that way, and new recorded tracks will have the same problem …

That indicates that the audio signal is being clipped before it gets to Audacity.

What are you recording and what settings are you using?
What are your settings in the device toolbar?

I’m recording with an AKG mic through an Alesis i/o2 (into USB port). the toolbars are as follows

Host Alsa
Playback device: default
Recording device: default: Front mic:0
Channels: 1 (Mono) Input

Recording level is 100%. I attached a screenshot in which you can see the clipping (just before 2 seconds on the first track) and the greyed-out area indicated some sort of filter.
For the third track, I turned the i/o gain down enough so that it didn’t redline – but as you can see the resulting input level is too low.

Here’s another screenshot I though might be useful. I told my 7 yo to scream (he loved that) and captured what audacity and PA vol control looked like when he did.
Maybe this helps?

Go to the “Input” tab of the volume control. I expect the recording level is set too high there.

Look again at the right side of the screenshot – the volume control. It’s not pegged; it’s in a very reasonable range. The input level is set to 100%, which is normal (transmit the entire signal).

I’m asking about the grey bars in audacity. Why is audacity set only to allow up to “0.5” in?

To put it another way:
I had my 7yo scream on purpose, so that you could see the clipping.
But why is the clipping at “0.5” instead of 1.0 ? Why isn’t that wave the full height of the track?

“100 %” is not guaranteed to be unity gain.
I can’t see what is happening in that (still) image - does the level go up to maximum when your child screams?

The “grey bars” simply indicate the half way position between the centre line and the thick blue lines.
See: http://manual.audacityteam.org/o/man/envelope_tool.html

As can be seen here, the grey bars do not restrict the level of the waveform:

As I said initially, the signal is being clipped before it gets to Audacity. You need to trace it through, starting from mic, and work out where it is being clipped.
Are you getting a full range signal in the recording tab of the volume control?

I suspect this could be the usual problem that Audacity treats a mono recording as half of a stereo pair. Have you tried setting Audacity to record in stereo in Device Toolbar?

If that gives you better volume then you can use the [X] at left of the redundant track to close it.