4 GB 44100 wav file opens 6 minutes only - help needed :/

ive been recording our “phono sessions” with audacity 2.1.0 win XP SP 3 - easy on CPU/RAM - awlays worked like a charm, but yesterday session ended up with a little disaster.

a 10+ hr session gave a 4,5 GB file which seemed to render flawlessly, but when i tried to open the file it sais it’s only 6 minutes - the wave ends with a glitch and i cannot open the whole thing with any audio editor.

i ve seen some tutorials on opening raw data but it doesnt work for me - browsing my hdd for raw file shows no files at all (i must have misunderstood the idea of a raw data file apparently)

When I copy the file from one drive to another it maintains the declared size, so maybe there is a way to connect the opening 6 minutes with the missing…10 hours? a few segments of the session were really good, and my guests will be heavily disappointed if i cannot deliver/publish the recording.

The WAV format is limited to files that are less than 4 GB, because of its use of a 32-bit unsigned integer to record the file size header

To work around this limitation you need to use a different file format such as FLAC, RF64 (available as an option when you select “other uncompressed files” as the file type), MP3 or OGG. Note that FLAC and RF64 are lossless formats, whereas MP3 and OGG are lossy (will lose some amount of sound quality).

If you still have the Audacity project, then all you need to do is to re-export to a suitable format. If you only have the corrupt WAV file, then I don’t know of any way to recover the lost data.

damn ;/ the longest sessions so far were 2,6 - 2,8 GB - yesterday show lasted from 8pm will 6am - i didnt know about the 4GB limit ;/ turth is everybody else around uses 320 kbps recording of long sessions and now i understand why they do so…

the 6 minutes that i am able to open is not the beginning as ive stated in the OP, it’s a mid part…

well it seems i f*****d this up big time, thanks for the reply.

Try File → Import → Raw Data.

Since Audacity will be ignoring the file header, you’ll have to enter the format details. You know it’s 44.1kHz and hopefully you know the bit depth and number of channels. Start with the unknown settings at their defaults and if you get “pure noise” try changing the offset to 1. (If it’s 24-bits you may have to try an offset of 2 in order to get the bytes aligned.) If it works, there will be a short noise at the beginning of the file where Audacity has converted the header to audio, but you can delete that.