3.4.1 error by opening aup-file (insert silence)

Hello there, a few of my older aup-files I can open now. Thanks for that! But some files I still cannot open. See the attachment.

I have to insert silence. But the file is shown already totaly silent. :wink:

Does anyone have an idea?

If you care to upload then post a link to a project that exhibits this behavior, I’ll take a look at it.

Thanks jademan for your offering.

At the bottom you find a link. But I realized that the behaviour of the project is different in audacity if I download the copy from the cloud as if I use the original file. Here comes the message that the project could not befound. Even if I take a working aut-file it doesn´t work anymore if I take a downloaded copy from the cloud. It is realy strange.

https://124383-my.sharepoint.com/:u:/g/personal/kemmerer_praxis-kemmerer_de/Ed6_9cBd4thIjkDwfhvr4QoBe_V0KKL9zSO69aixM_oILQ?e=25eWFT

It may be helpful to “unhide” your file extensions so you can tell whether you are referring to a legacy .AUP pointer file or the new unitary .AUP3 project file. There is a show/hide box in Windows File Explorer that keeps these extensions from being hidden: Common file name extensions in Windows - Microsoft Support

So since Audacity 3.0, all projects are now being rewritten in a single unitary .AUP3 file structure. Unitary means everything, pointers and data, are all contained within a singe .AUP3 file.

In Audacity 2.4.2 and earlier, projects were written in multiple files: the .AUP file contains pointers only to possibly hundreds of smaller .AU data-only files (yes, a third file extension), contained within a XXX_data subdirectory. So if you copy the .AUP file only you will not have a project. This confusion is one of the principle reasons the .AUP3 unitary files were introduced.

Yes. You would have to take the working xxx.AUP file along with the associated xxx_data directory and all of its sub-directories in order for it to work properly.

Thanx jademan!

The files are from 2009/ 2010. I found them after all that years again and they are important for me.

I checked the settings. The extensions are allowed. You can see it in the attachment. You have another idea?

grafik

Good. :grinning: Yes. You have to take the working xxx.AUP file along with the associated xxx_data directory and all of its sub-directories in order for it to work properly.

Ah, now I understand what you mean. :blush: The question is now for me: how can I bring them together into audacity? How can I connect the aup-file and the _data-files so that audacity accepts that? :nerd_face:

I believe it is sufficient that both items have the same name. That is if the first is “123.aup”, then the other must be “123_data”. If that doesn’t work, post the .aup file, or open the .aup file in notepad and post a screenshot.

Unfortunately it does not work. Here I send you the screenshot of the aup-file, opened in “Editor”. Maybe you see the solution. :slight_smile:

So I can see that your data directory should be named “ferrytale_data” and your .aup file should be named “ferrytale.aup”. Also, “ferrytale_data” should have a dozen or little .au files buried in nested folders. You can actually see these .au files being itemized within the .aup file. Do they exist ?

Here I send you the data of a (not working-) project over trasfernow, so you can try. Transfernow fragmented the _data-file. You have to open a new file with the corresponding name and all that subfiles. Thanx! :slight_smile:

Does this file open for you in 3.3.3 ? (I had to tweak the directory structure first).

Problem reported to developers here: .AUP file fails to load in 3.4 · Issue #5679 · audacity/audacity · GitHub

I just came to this forum to investigate this same problem. I tried to open an ancient “xxx.aup” file (last modified in May 2009) in Audacity v 3.4.2, and received the same “error opening file-inserting silence” message described above. The “xxx_data” folder was present in the same parent folder with the “xxx.aup” file, and yet I received this error message anyway. I uninstalled v 3.4.2 and installed an older version, in this case, v 3.0.0 just a wild guess, and the xxx.aup file opens fine with it. It even allows the option to save the project as an xxx.aup3 file.
So as long as I save all these old files as .aup3, I should be able to reinstall v 3.4.2 and not encounter this problem anymore?

Yes. In fact, this is what developers are recommending. (Personally, I think there is a bug that should be fixed - but this is a better long term solution.)

Just so you know, when you take a blind stab, you are better off taking the latest patch of a release: major.minor.patch. So take 3.0.5, not 3.0.0; 3.3.3, not 3.3.0.

1 Like

Hey, @orogon - could you please try to open this project via Audacity 3.3.3, save it there, and try to re-open in 3.4.2?

Hello, @mugen2x, @jademan,

I tryed it with one file. It really worked. Now the file opens in 3.4.2. :smiley:

Thank you very much for your help! :+1: