3.2.3 gets stuck on 'Verifying "Audacity.app'

Version of Audacity 3.2.3
OS X 10.13.6

It’s been a number of years since I tried a new version of Audacity so downloaded 3.2.3, dragged it to the Applications folder as usual, and tried to start it. I get the pop up (attached) saying it’s verifying. This goes on indefinitely until I kill it.

Ever curious I tried fresh downloads of older versions including 2.4.2, 3.0.3, 3.1.0, 3.2.0 and 3.2.2. All of these run just fine. Only when I try 3.2.3 do I get the issue described above.

To be honest, this OSX MacBookPro is getting a bit long in the tooth (2015 and still kicking) and a hardware upgrade may be forthcoming during the next sale event. Perhaps 3.2.3 will run on fresh hardware and OS. Regardless, I thought reporting the above behavior is something you might like to know… something bold clearly changed between 3.2.2 and 3.2.3.
Audacity 2022-12-30 at 9.34.49 PM.png

Thanks for the report. :smiley:

On the Audacity Mac download page here: https://www.audacityteam.org/download/mac/, it states:

System Requirements
Audacity is for Macs running macOS 13 Ventura, macOS 12 Monterey, macOS 11 Big Sur, 10.15 Catalina, 10.14 Mojave and 10.13 High Sierra.

Audacity runs best with at least 2 GB RAM and a 2 GHz processor.

For lengthy multi-track projects, we recommend a minimum of 4 GB RAM and 4 GHz processor.


Older Mac operating systems/PPC Macs
For Mac OS 9 and Mac OS 10.0 through macOS 10.12, legacy Universal binary versions of Audacity with Intel and PPC support are > still available> .

I am glad 3.2.2 seems to be working for you… :smiley:

I am having the same problem and have reverted to 3.2.2 (which works great!)
Perhaps the compatibility list should be updated, as High Sierra (10.13.6) no longer appears to be compatible with 3.2.3

The developers are looking into this… See: https://github.com/audacity/audacity/issues/4139 which says:

After further investigation, I can reproduce this issue specifically when updating the app from to 3.2.3; however, fresh installs downloaded from audacityteam.org work perfectly fine.

Also having this same issue. Mac OS 10.13.2.

Also having this issue w/ 3.2.3
OSX 10.14.6
Mac Tower running 3.2Ghz Quad-Core Intel Xeon, 24GB RAM

Had the same issue on Mojave. It worked after I installed the x86 package instead of the universal package.

3.2.3 fails for me on High Sierra 10.13.6. Downloaded the file and it hangs “verifying” as others have described.
Tried various things to get past this with no success.
I suspect that something in the 3.2.3 package does not verify on old macOS versions.

I visited https://www.fosshub.com/Audacity-old.html and downloaded 3.2.2 and was able to run the app.

If you’re still running into this issue, the workaround is to install the binary specific to your system from https://github.com/audacity/audacity/releases/latest
The macOS-x.x.x-arm64.dmg is for Apple Silicon (M1/M2/…) macs, the macOS-x.x.x-x86_64.dmg is for Intel macs.

having this issue too but my mac definitely meets requirements