3.0 does not record or playback sound in Catalina 10.15.7

I have been using Audacity for many years, but… since I moved from an old MacBook Pro to a new one (2019 - 2.3 GHz 8-Core Intel Core i9) running under Catalina 10.15.7, Audacity 3.0.0 or 2.x.x do not record or playback any sound.

I have tried everything I read in the Forum but nothing works.
Audacity does not show either in Preferences → Security & Privacy → Microphone.

Please, see the screen Shots attached.
Thanks for your help. Ricardo
Screen Shot 2021-03-06 at 8.26.00 PM.jpg
Screen Shot 2021-03-06 at 8.27.22 PM.jpg

ricardo57, Windows guy here. I see you have been struggling with this issue for several months now. Quick question: do you get the error when you try to play a chirp or tone? Or is the issue always related to recording?

Have you tried the suggestion in this post? https://forum.audacityteam.org/t/2-4-2-on-catalina-10-15-7-no-sound-on-recording/59092/23

Hello jademan. Thanks for your post!!
Yes, I was having the same problem when generating a chirp sound.
I tried the different suggestions using Terminal but didn’t work.

Now, I followed your suggestion and deleted the 142 plug-ins in the Library/Audio/Plug-Ins/Components folder and … Audacity works!!
Great, many thanks…!!

Now the issue is that I was using a lot my plug-ins. I brought back some (about 6-7) to the Components folder and Audacity work and the plug-ins, too, but if I bring back all of those plug-ins, then nothing works. Is there a limit in the number of plug-ins Audacity recognizes now or is it a different problem? I had them all working in my previous version of Audacity 2.4.x using an older MacBook Pro running Mojave.

Thank you again!
Ideas about how to have the plug-ins working, are very welcomed :slight_smile:

There isn’t a limit to the number. There’s probably a rogue plug-in in there that’s causing the problem.
Try putting them in say 10 at a time. If Audacity stops working then take those ten out and replace them one at a time.

… and if you zero in on the offending rascal, please report back so others know so they aren’t chasing their tails. And perhaps developers can even duplicate it and fix it. :smiley:

Thanks, steve and jademan.
I couldn’t identify any specific plug-in yet but will work on it and will report any findings.