2nd track won't record while playing 1st track

Audacity 2.1.1 Windows 10. Just downloaded latest version of Audacity. Recording through Behringer UMC204HD USB. Ticked “playthrough other tracks while recording (overdub)” and “always record on a new track” and ticked “overdub” under transport options. 1st track recorded fine but when I hit “record” for 2nd track the track is created but no waveform appears on it. Never had this problem with Audacity version I used 2 yrs ago. Can anyone tell me if I am missing some setting. Thanks, AL

track is created but no waveform appears on it.

The structure of the second track appears but the cursor never leaves home port, or the structure appears with a moving cursor which traces a straight line and no blue waves. Those are different problems.


Thanks for the reply, the structure appears but the curser doesn’t move. When I hit “play” I can hear the first track and the 2nd part I am adding. Allan

Audacity 2.1.1 Windows 10. Just downloaded latest version of Audacity. Recording through Behringer UMC204HD USB. Ticked “playthrough other tracks while recording (overdub)” and “always record on a new track” and ticked “overdub” under transport options. 1st track recorded fine but when I hit “record” for 2nd track the track structure appears but the cursor doesn’t move from home port. If I just hit “play” and speak into the microphone I can hear both tracks. Can anyone tell me if I am missing some setting. Thanks, AL

I also have this problem. Has a solution been found? It is quite annoying to have an interface and not be able to use it…

I posted a similar question 2 days ago. I didn’t realize that this subject was already broached, and clearly there has been no replies here either
What worked so seamlessly in the previous version seems to be so unintuitive in this version.

I think this is the very basic of recording music- that you are able to hear the melody you first create to then harmonize against it, but for the life of me, I don’t understand why I can’t hear what I record on the first track while recording the second

It wasn’t broken before, but now it is and and sadly there is no one to help. I wish I could go back to the old simple version when I just hit ‘record’ for one track, then hit it again to record on the same track whilst hearing what I recorded first.

I really hope someone will be able to answer this question for non techies like myself. The quality of the sound is also much worse. I guess it’s human nature to improve upon what’s already working

It’s not unusual for the project to outstrip the elves. Help is an X4 job.

We not only have to know how the program works, but typical symptoms when it doesn’t, typical user errors, and strategies for digging you out of trouble after you dug yourself in.

Let’s try this. Assume Audacity 2.2.2. Early Audacity 2.x.x versions can be dangerous.

Audacity > Edit > Preferences > Recording. [X] New Track and [X] Detect Dropouts should be the only things selected.

Open your backing track or record a short one for testing. You won’t hear anything and it doesn’t matter what the music is. I made mine by touching the guitar cable tip.

Select the whole backing track by clicking just right of the up arrow.
Every time you press Record and Stop you should get a new track just under the backing track. Record, Stop, Record, Stop, Record, Stop. Click the graphic if it doesn’t fit.
Screen Shot 2018-03-09 at 20.06.03.png
Everybody on board?


It took about ten minutes to set up Recording Latency and this is me doing Julie Andrews against the metronome backing track. Three times.

It would have been faster but I can never remember which way the latency adjustment goes. “If it’s too early, you make the adjustment smaller. No, wait. That can’t be right.”


Needing to select the backing track did catch me off guard. I don’t think you used to have to do that.

Anyway, make sure you have your device selected for both playback and record in the Audacity device toolbar. I’m using a Behringer UM2, so my sound device is USB Audio CODEC for both.

The quality of the sound is also much worse.

If you’re on Windows make sure all your conferencing and voice processing is turned off.

To paraphrase the overdubbing tutorial, make darn sure you can make a plain recording perfectly before you start overdubbing. Once you set up for overdubbing it’s killer difficult to start troubleshooting your sound system.

Now go back to Audacity > Edit > Preferences > Recording and select Other tracks…Overdubbing > OK.

Back to the timeline. Generate > Metronome. Do that for about 20 seconds or so.

When you get done. Select the metronome track by clicking just right of the up arrow. Press record and your microphone should activate and push the sound into your headphones. Jam your headphones against the microphone so the metronome gets recorded.

Stop. The difference between the two tracks is your Recording Latency Adjustment.

Audacity > Edit > Preferences > Devices > Latency: Track shift > OK.

Adjust that value by the number Audacity gave you when you compared the two metronome tracks.

Keep adjusting and recording until the two clicks line up.
Screen Shot 2018-03-09 at 20.38.30.png
I think you’re done. Note you can’t plug headphones into the computer to do this. Your device or microphone has to support Zero Latency Monitoring.

This is the whole setup for my performance.
That’s an AKG public address (Tannoy) microphone and the cheap headphones I picked up in Hawaii all plugged into a Behringer UM2. Push the Direct Monitor button on the front for Zero Latency Monitoring so I can listen to both sides of the recording at the same time. I called that perfect overdubbing. You can overdub without that, but it’s a lot trickier and most performers want to hear themselves, plus it helps with automatic volume when you can hear yourself.

I think most of this is still accurate, but I need to go back in and make that track selection change.



Note the above is a burning rubber fast overview of the much more detailed tutorial, and there’s nothing in here about all the gotchas you can run into with the different computer types and microphones.

The tutorial has three different zero latency devices I wrote up as examples. One microphone, one microphone amplifier and one stand-alone interface. I got the UM2 after that and it works just fine, too.

Behringer makes some pretty cool stuff.


One other quick note. Overdubbing is stressy for a computer. It has to play your backing track(s) exactly perfectly and record the new track also exactly perfectly. If your computer is right on the edge of running out of resources, you could be able to record or play back, but doing both at once is beyond it.

Problems like this show up when you set Record Latency. For Some Reason, you can’t ever get there because the computer skips and delays at random. It can’t keep up. The first time you send actual sound through it, the sound gets trashed.

There is no easy fix. If you close all the apps and increase the free space, optimize, etc. and still no joy, then you have a system that won’t overdub, possibly ever.

That’s not to say you can’t get your production done. It’s just you can’t use the convenient shortcuts.

Record or produce the backing track. Export it as stand-alone sound file and transfer it to your Personal Music Device and play that into your headphones while you record the second track on the computer. Mix the second track with the first one (however many steps you need to get there), export that mix and play it in your Personal Music Device.

Repeat. The computer is only ever doing one single sound job.

You can shortcut that a bit if you’re good enough to perform all the parts against the backing track without hearing all the others. In that case you can record the guitar against the backing track, the bass line against the backing track, the drum line against the backing track, etc. Dump them all into Audacity and edit your brains out. This is where the drum rim-shot lead-in is valuable. Tick, tick, tick, tick, Music.

There is also Generating Click Track instead of Metronome. In that case you can custom generate your own backing track with emphasis, for example, as 4:4 time.

Boom, tick, tick, tick, Boom, tick, tick…

That’s a lot more involved which is why the two-control metronome was split off a while back. You don’t need a user interface scientist to drive a metronome.


Check Bitrate for input and output devices . That fixed it for me.

On Windows 10:
Sound Settings->Sound Control Panel->select your device->Properties->Advanced->Default Format

Make sure your input and output devices have same settings.

Hey Darman786, thank you, that solved it. Just updated to Windows 10 and the cursor wouldn’t move on the second track so I just went did exactly what you said but instead of selecting default I chose bitrate 44100 studio quality because that’s what audacity had when I opened it. Thanks again m8! :mrgreen: