2.4.2 loopback record issue


I installed 2.4.2. today and have an issue while recording something like a Youtube video from the browser (Edge Chromium). The recording is very chopped up.

I have a Scarlett 2i2 3rd gen audio interface, driver version 3.6.0 1822, which is the newest version I think. In Audacity I have “Windows WASAPI” selected as host and “Focusrite USB Audio - loopback” as the recording device. All the other host options like MME and Windows Direct Sound and device options like "Analog 1+2 (Focusrite USB Audio - loopback), “Input - Realtek Audio” and "Stereo Mix (Realtek Audio) don’t record anything.

Changing the buffer lenghts and latency compensation didn’t change anything. Neither did changing the sample rate and sample format.

Attached is an audio clip of what a recording sounds like. I hope someone can help me on this. I’m using Audacity for many years and don’t want to switch to another programme.


Thanks in advance!

After another 4 hours of trying almost everything, I still didn’t manage to find a solution. I tried using different Audacity versions including the one from the Windows 10 store, which is version 2.3.3. I went back in versions as far as 2.1.0 which has the same problem but really not as bad. I also tested recording with other programs such as Goldwave. There the recording/playback is flawless. So it seems to be a problem with Audacity.

Another thing I found out: The problem isn’t always there with 2.4.2. Sometimes after minimizing and maximizing Audacity a couple of times the playback of the recording is perfect. So I think it’s not a recording issue but has something to do with the playback. So I de- and re-installed the Focusrite Audio driver, de- and re-installed Audacity, restarted my PC but the Problem is still there most of the time. Changing the Focusrite settings didn’t make a difference - sample rate is 48k, buffer size is 256 samples. In Windows the Focusrite is the standard playback device, the settings match those in Audacity (48k, 16bit). It can’t be a hardware issue or not enough RAM or something. Mainboard is a Gigabyte Aorus X470 Ultra Gaming, AMD Ryzen 2600, 16 GB RAM and a WD Black SN750 NVMe SSD.

For now it seems like I’m stuck with either a really old version of Audacity or another programme.

I’m surprised that “Stereo Mix (Realtek Audio)” didn’t work. Does that work if you unplug the focusrite and restart Audacity?
“Stereo Mix” should still give excellent quality recording even though it’s only the on-board Realtek device, because it should be capturing the data stream and avoiding the analog circuitry. The benefit of the focusrite is that it has much better analog circuitry than a typical on-board sound card, but that shouldn’t make any difference when capturing computer playback.

Thanks for the reply!

I tried it and it works. I mean I had to connect Headphones to the 3.5mm out (green) on the MB to get it activated but the recording and playback with the Stereo Mix is flawless. But as soon as I reconnect the Focusrite, Stereo Mix doesn’t work any more even though it’s still the recording standard device in the Windows audio settings. I HAVE to select “Focusrite USB Audio (loopback)” in Audacity to be able to record what’s playing on youtube or whatever source - and the recording/playback sounds as awful as shown in my first post.

As per my second post I went even further back in Audacity versions and use 2.0.6 now which works very well.

It’s so weird, I don’t know why 2.4.2 doesn’t work for me. But as long as 2.0.6 does the job I’m alright with it.