[2.1.2/2.2.2] Recording Suddenly Not Working

Hi, I’ve suddenly run into a rather annoying anomaly. I’ve been using Audacity for 2 years without any problems, but just this morning (after I installed an update for my computer), I can’t press the record button without being greeting with “Error opening sound device. Try changing the audio host, recording device and the project sample rate.” I tried running through all the input devices I have available, uninstalled and reinstalled Audacity entirely (as well as updating it), and went through every single step in the manual after clicking the help button, and I still can’t get it to work. I was using version 2.1.2 prior to switching over to the latest version available, 2.2.2.

In Windows, there is a tick to tell the installer to wipe clean all the preferences and settings. Did you select that? If you didn’t, Audacity will try to retain the preferences and settings from the old install.

What are you recording?


Yeah, I’ve already tried that. Still nothin’.

I’m trying to record various sound effects from multiple arcade games.

Hmm…actually, I think this might be an issue with my computer in general, after further investigation. Other programs that normally work fine, such as Discord, aren’t able to pick up anything at all. Guess there isn’t much I can do with Audacity specifically now that I know it’s also a problem with other things. Whoops.

I’m trying to record various sound effects from multiple arcade games.

Are the arcade games at the end of a microphone? Are you recording YouTube game sound? Built-in Microphone? Don’t make us work for this.

Whatever you do, Windows has to know all about it first. Right click the microphone lower right > Recording Devices (or something like that). Do you see your device or service in the list? Audacity isn’t going to do a thing until Windows is happy.

Once you select your “thing,” the Windows sound meter should work.

Then open up Audacity.