2.1.1 repeatedly freezes... Ubuntu 15.04 - 64

Hey guys… I’m new to audacity (and to Ubuntu), and this is my first post here…

I’m trying to make an audiobook in Audacity, and after watching a few video tutorials, and having happily experimented with 2.1.1 yesterday, I decided to start actually working on my project today… Everything went very well at first, but then Audacity started to systematically freeze on me, after I had recorded like 12 minutes of audio…

First the the freezes, then the audio got corrupted, then the saved files wouldn’t open… I’m at a loss here… :open_mouth:

If this goes on, I’m not going to get very far, as my audiobook requires around 10 hours of speech…

Since I don’t think I did anything special or wrong, I don’t even know what to describe… Just some noise reduction and a bit of editing…

Maybe it’s because I use Shift + R to ‘resume the recording’ instead of allowing Audacity to create a new track each time I have to go on?..

Or is it a RAM thing?.. I have 4 Gigs on my laptop, I thought that would be more than enough for speech recording…

I use a Rode Podcaster microphone, it works quite well in Ubuntu, plus Transmission is running (with quite a few files I must admit, around 100) while I use Audacity… Other than that, I honestly don’t know what other info I could add…

Any ideas please?.. :neutral_face:

Assuming you are recording using the “pulse” or “default” recording device in Device Toolbar, try setting the PULSE_LATENCY_MSEC value as per http://wiki.audacityteam.org/wiki/Linux_Issues#pulse.

Alternatively choose the “USB Audio CODEC - (hw: 1.0)” or similar recording device in Audacity which bypasses pulse and should not have the freezing problem. This will work as long as only Audacity uses the mic.

Make sure you have enough disk space (look at Edit > Preferences… : “Directories” section). 10 hours recording is 12 GB of space by default. Every edit of the complete recording is another 12 GB used.

Transmission is running (with quite a few files I must admit, around 100) while I use Audacity…

Large amounts of BitTorrent traffic while recording is not exactly going to help. You could get recording dropouts.


Hey Gale… Thanks for the very quick reply! :slight_smile:

I think I am already using the parameters you described… Here’s a picture of my settings

I still have almost 400 GB of free disk space, so I don’t think that the size of the audio files will be an issue for the computer… But is it OK to do it all in one big file, or is it safer to make a series of 30 minutes recordings, and only combine them at the very end of the process?

Today I remembered I did something different when it all went wrong: On the first day I just used the microphone’s built-in audio jack to monitor my own voice while recording, but on the day Audacity started freezing, I was using the ‘Software Playtrough’ function to do that… Is it known to cause issues?..

Thanks again!

PS: I will quit torrenting while I make my recordings! :wink:

USB audio has a habit of eventually running out of bandwidth and stalling. Then you have to restart Audacity, or disconnect/reconnect the device, or restart the computer.

I would not push USB mics beyond a few hours at a time, personally.

You can SHIFT-click on the Record button to start recording at the end of the selected track, so keeping the sections of recording on one track.

That’s your issue. If you look at your settings you’re using “default” (that is, pulse) as the playback device.

If you don’t want to monitor in the mic, you would have to configure pulse latency as above for that to work, or choose the (hw:0, ) playback device in Audacity. If you have more than one onboard playback device, you may have to use ALSAmixer to select the correct playback device for the (hw: 0) choice to use.

Any software playthrough will have latency, especially pulse, so you will hear yourself late. You probably got no delay monitoring in the mic, because that is hardware playthrough, so that is probably a better choice.


All right then, that’s settled!.. I’ll use the mic to monitor!

Thanks for your help Gale! :slight_smile: