Windows WASAPI Not picking up audio [SOLVED]


I’m trying to record audio that’s playing on my computer, but audacity seems to fail to pick up any audio. I’ve already read the online manuals for recording computer audio, and i double-checked everything. Still nothing gets picked up. Switching devices seems to “record something” but it’s all just noise at an incredibly low volume, almost a straight line with little dips all over. I have checked a few other forums that had Windows WASAPI problems but they do not cover anything that i’m having problems with. Any and all help is appreciated !


Audacity version: 2.3.3
Windows version: 10.0.18363

Please post the full “Audio Device Info” so that we can see Audacity’s audio device configuration (see:

Here you go! Didn’t think to post this for some reason
deviceinfo.txt (9.96 KB)

:slight_smile: It can be quite a handy little tool, but a lot of people don’t know it is there. It’s one of those things that isn’t at all useful, until it is :smiley:

Currently the settings in the Device Toolbar are:

  • host: WASAPI
  • Recording Device: 19 Device name: Speakers (High Definition Audio Device) (loopback)
  • Playback Device: 18 - Speakers (High Definition Audio Device)

This is curious, because the “Microphone (High Definition Audio Device)” and “Speakers (High Definition Audio)” appear to be duplicated. I’m guessing that is related to the “Steam” device. What is the “Steam” device? Have you installed some kind of “virtual device” for recording games?

You also have:

Recording Device:
Device ID: 17
Device name: Speakers (High Definition Audio Device) (loopback)

Playback Device:
Device ID: 16
Device name: Speakers (High Definition Audio Device)

I’d suggest that you try every combination of devices 16, 17, 18, 19 and see if one of those combinations works.

Steam device seems to be from the Steam Application from Valve, so yes it is related to video games.
Also, the duplicated might be because my computer has a built-in speaker, and i am using headphones with a microphone which are both plugged into the rear ports, since plugging them into the front ports makes the computer preference the internal speaks as opposed to the headphone speakers for some reason.

Aside from that, i’ve tried swapping the combinations as you have suggested, but i cannot seem to find the IDs 16 or 17 in audacity (The duplicate items seem to either be the same ID, or they’re just displaying as the same ID for some reason I don’t know, it’s confusing me). They seem to not appear in the devices list. I’ve tried looking at my system sounds settings and i still only see the two “Speakers High Definition Audio Device” along with the “Speakers Steam Streaming Microphone” and “Speakers Steam Streaming Speakers” located under the Playback tab, and the two “Microphone High Definition Audio Device” (one of them is not plugged in, i’m guessing that’s an internal one?) and a “Microphone Steam Streaming Microphone” device. So it seems like the System Sounds are displaying the same thing as what Audacity is picking up, but i can indeed see the 16 and 17 IDs in the file i’ve sent.

What is it that you are trying to record? If it’s a game, how is that “Steam” device supposed to be used?

Really i just want to record any computer audio, Pretty much anything that i hear from my headphones i want the computer to pick up.
As for the steam device, i gotta be real with you i got no clue. I didn’t even know it was there until i opened up audacity

I’m not sure what to advise. The “audio device info” comes from the sound drivers, and it looks distinctly odd. If it were me, I’d try updating the sound card drivers with the latest version from the manufacturer, but that can be risky if you’re not sure what you are doing (you could end up with no sound at all).

Is your computer a laptop or a full size computer? What (physical) audio inputs / outputs does it have?

Just did a drivers update. Can confirm i already have the latest drivers according to Device Manager.

I have a full computer. It contains a headphone and mic audio jack on the front, and a headphones and mic audio jack on the back as well (the ones i’m using). My headphones also do not use a USB plug, just in case

So i figured out the problem.

I’m using headphones plugged into my rear speakers on both the headphone and microphone jack. My computer also has an internal speaker, so there are 2 “High Definition Audio Devices” that show up in the audacity device list. There are also 2 of those that show up in my sound settings. Both of them are currently enabled.

Turns out, disabling the one i wasn’t using (i found this out by opening the sound mixer, and switching to the audio device that had no audio channels opened on it, clicking on the speaker, and disabling it from there) perfectly fixed the problem for me. I have no clue why this ended up fixing it, but i’m glad it did.

The audio it records does seam a little bit quiet, but amplifying it hopefully won’t be too big of a problem!
(is there a way to mark a reply as the solution?)

Super. Glad you’ve got it working.
Topic closed as “solved”