Using 'Custom' setting to Export in 6 Channels...

Hello, this is my first post and I PROMISE that I searched the forums (although my 5.1 or 6 were ‘ignored’ every time which kind of defeated the purpose… :slight_smile: ) And I even tried to click on a specific link that was supposed to show me precisely what I’m asking, but it did not work…

Okay, I have a DTS file loaded in Audacity (6 channels) I’ve edited it and I would LOVE to export it in SOME 6 channel output if I can. I’ve even chosen the ‘Customize FFmpeg’ option and I’ve even tantalizingly seen the very nice 6 channel picture and then I hit ‘Okay’ and nothing happened…???

It seems kind of weird that it LOOKS like it is going to export in 6 channels, but then it just sits there. Could someone PLEASE tell me what I am missing?

Thanks kindly!


Where exactly was the link that did not work (the web address)?

I assume you have enabled “Use custom mix” in Import / Export Preferences.

What option are you selecting after choosing “Custom FFmpeg export”? I choose “DTS” under “Format” and I get an error that says the codec is not built into FFmpeg (which may be correct). Don’t you see that error?

None of the FFmpeg options will work at all unless you install FFmpeg .

The only way I can get it to work is to get one of the “32-bit Builds (Static)” from (these are much more recent builds of FFmpeg than Audacity can currently support for general export and import). Don’t get a “shared” build.

When you export, choose “(external program)”. Click “Options”. Browse to the location where you have downloaded the Zeranoe FFmpeg and select and open ffmpeg.exe (it should be in the “bin” folder). This will show you the path to ffmpeg.exe wrapped in quotes.

Add the following after the path to ffmpeg.exe

-i - -acodec dca -strict -2 "%f"

So in my case the complete command was:

"C:Program Files (x86)ffmpeg-1.0-win32-staticbinffmpeg.exe" -i - -acodec dca -strict -2 "%f"

Click OK on the options, then enter your filename with the DTS extension at the end, for example “filmscore.dts” (without quotes).

This is the Manual page that describes using the Audacity command-line exporter:
Audacity Manual .


Hi Gale!

Thank you kindly for your fast and very thorough reply. I did indeed place the settings as you have said and yes, I have installed “32 bit FFmpeg for Audacity Only” and it tells me that is already sees it. So all that is fine.

I DID happen in the meantime to stumble upon a nice thorough Blu-ray authoring tutorial on DOOM or some such, and within it’s lengthy instructions it did show in detail how to export from the 6 Mono files using ‘Other Uncompressed Options’ simply choosing either WAV or FLAC format (I wasn’t aware that they supported multi-channel files) NOW, with trying THAT I at least did get it to do something and not just sit there like it did when I tried the ‘Custom FFmpeg’ choice and it DID indeed render a file in each case. One FLAC and one WAV. In both cases I got the nice diagram showing the 6 channels going directly to 6 channels.

BUT… When I then went to try and listen to either file (using VLC because I figure it plays bloody everything) I sat there as the progress bar moved naturally as if the song was playing, but there was only silence…


Sorry to be so long-winded, but here is a simple synopsis:

  1. When trying to use the ‘Custom FFmpeg’, then seeing the 6 channel diagram, when I then hit ‘OKAY’ it just sat there and did nothing. A resulting file showed on my desktop, but it was ‘0’ bytes in size.

  2. When I used either WAV or FLAC as my choice, it DID render one file in each occasion, but I cannot hear anything when trying to place either of them back with VLC. And I checked each file using MediaTab and supposedly in each case it showed an uncompressed 16 bit audio file and bit rates like SOMETHING was there.

And, as far as the command line stuff… Well, I’m sorry to say that that is WAY beyond my ability I’m afraid; a bit too complicated. BTW, SHOULD VLC be able to play the uncompressed 16 bit WAV or FLAC files that Audacity generated? I’m pretty sure it plays back 5.1 audio files because the MKV snippet that I extracted from the movie that contains the original DTS file plays just fine with along the video (the snippet is a song from the closing credits of a movie that is about 3 1/2 minutes in length.

Here were the steps I took:

  1. I took the 4.4 Gig movie file (MKV containing MPEG4 video & DTS audio) and I used MKV Extract to strip out the full DTS soundtrack.

  2. I then loaded the DTS file into Audacity and edited out everything except the 3 1/2 minute song. All 6 Mono tracks were shown and played back just fine in Audacity (I know it wasn’t playing back all 6 together, but everything seemed to track and be working just fine.

  3. Here is where I’m stumped. I cannot seem to export the damn thin properly into a playable format that I can hear (the WAV & FLAC renderings) And, I cannot render anything at all using the ‘Custom FFmpeg’ option.

So, I am sitting here with this nice 3 1/2 minute song sitting in Audacity in 6 lovely Mono tracks, and here I am…

I hope you don’t mind my being so detailed, but I wanted you to understand where I am in this. BTW, your search function is so beyond me, there is NO bloody way for me to find where that link was. But, later on before I got your reply, I DID see another link about the same thing and this one did take me to the manual where it explained in detail how to use the ‘Custom FFmpeg’ option. But, when I hit ‘OKAY’, nada…

Now, I DO have the MKV snippet that has both video and audio that I painstakingly extracted from the original 4.4 Gig file using Avidemux (that took a while!) And I can play the MKV snippet with VLC or on my Blu-ray player (if I wanna hear it in 5.1) just fine. But the edit isn’t that great with Avidemux and it has like 10 seconds before the song starts and about 10 seconds after the song ends, not to mention the accompanying video which I don’t need. So, that is why I used Audacity, so I could get the edit exactly right. But, now that I have, I cannot for the life of me export it in any usable way. (BTW, the song is by RUSH’s Alex Lifeson who does this GREAT little song at the end of the film ‘DOUBLE’, so I promise you it is worth it! :slight_smile: )

Thank you again for all your help!

I’m sorry… I forgot one thing; I don’t know if it is important.

The original Mono files I extracted are sampled at a rate of 16 bit, 48,000; but when I go to export them using the WAV output, it only gives me a choice of 16 bit, 44,100. So, I don’t know if that has anything to do with anything.


And it shows lines connecting the audio tracks to the audio file channels as im this diagram? Audacity Manual

An easy way to test your exported file - try importing it onto Audacity. If it has correctly exported as a 6 channel file you should get 6 tracks in Audacity.

Thank you. I hadn’t thought of putting the resulting FLAC & WAV files back into Audacity to take a look at them.

I’ll figure it out. Appreciate the replies guys…

Man, this sure is weird…

Like I had mentioned, I have the 6 channels loaded just fine in Audacity; They all look great on each track. I can play it back and it sound perfect.


I go ahead and export it as either a 6 channel FLAC or WAV file; and it LOOKS like it is rendering the files just fine. BUT, as you just suggested, when I then go and load the resulting FLAC / WAV files back into Audacity, guess what…? There’s NOTHING there! I mean 6 channels of straight lines. Damned weirdest thing…

I"m pretty sure I have all the settings right and it sure LOOKS like everything should come out just right, but it doesn’t.

Also, as I had mentioned, just to try it I went ahead and changed the default export setting to 48,000, 16 bit which is the way the 6 Mono tracks are, but no go…

Sure is a puzzler, wouldn’t you say?

Any further thoughts or suggestions would be great if you guys aren’t ready to hang yourselves yet! :slight_smile:




Okay, for whatever reason on God’s Green Earth I have NO idea, but I thought ‘Okay, I saved the project so let’s try simply re-opening it in Audacity again and see what happens’ and BINGO! All of the sudden it exported both the WAV and FLAC files just fine! And I was able to listen to both of them with VLC :slight_smile:

So, I can see why you guys here might have been a bit perplexed, but apparently there WASN’T any technical reason why this wasn’t working; apparently, maybe my first project may have crashed or something weird and simply stopped working, but when I re-opened the EXACT same project again, then BOOM, I got it!

Thank you kindly for putting up with my mysterious situation; NOTHING is more frustrating then when you are doing EVERYTHING right and it still doesn’t work!



Congratulations :slight_smile:

If they meant “Other Uncompressed Files”, FLAC isn’t in there on Windows versions of Audacity (it is in there on Linux).

For the number of channels Audacity supports in exported files, see Audacity Manual

As explained in the “Custom FFmepg” dialogue, not all combinations are compatible. And they often don’t show an error when they fail, which is not so good.

Are you talking about the search in the Forum? The best way to find a page you have visited is often to look it up in the browser history. But don’t worry about it if you cannot find it easily.


I know this is a very old thread but it is the only resource I have found which has been any use to me. I have been trying to get six mono audio tracks into a 5.1 mix for burning to a bluray using Encore. The only thing that has even partially worked has been following Gales suggestion using the external 32bit Zeranoe build and following the command line instructions. Whilst it built a bluray and I got something out of the centre and surround channels, (which is a first) unfortunately the sound is completely clipped and garbled. I assume this is som6to do with a bit-rate setting or something? Any ideas?

Hi, I’ve also been trying to export 6 channel PCM to DTS and using Gale’s instruction has worked for shorter clips.
However with longer files (1.5 hours) I’m consistently getting an error which results in a truncated encode around the 24 min mark.

[pcm_f32le @ 000002b06c531280] Multiple frames in a packet.
[pcm_f32le @ 000002b06c531280] Invalid PCM packet, data has size 8 but at least a size of 24 was expected
Error while decoding stream #0:0: Invalid data found when processing input

It’s not a disk space problem. I’m able to export the 5.1 to wav and FLAC - FLAC is what i’ve resorted to using for now
but was hoping to get this DTS sorted out if anybody has any insight on what may be the cause of the error. lmk thx