Two problems: [1] audio in is only mono and [2] soft-play...

Two problems: [1] audio in is only mono and [2] soft-play does not always play audio at all times


[1] I am trying to record audio using a USB adapter, to my Macbook. The adapter has a mic-line in and a stereo line out, which goes to my sound system. PROBLEM: I am only getting mono audio. (I do not have a direct line in for 3.5mm audio, so I have to use an adapter.) I called the company and they did not have any recommendation for an adapter that can record stereo audio to the USB adapter, rather than only mono. In Audacity, there is no way for me to select Mono. The pulldown menu just says 1 (Mono) – there is no option for me to select 2 (Stereo) in any menu.

How can I get stereo audio in?

[2] Also, I am using Audacity and I cannot get the audio to just “always play.” Back in version 1.0.x, there used to be a checkbox called “soft play through,” and it would play anything that came into the adapter/Macbook at all times. This was great for me, because when I went to record the input, I could also continue to listen to whatever I was playing…

…but with this new Audacity 2, I have to select both “soft play through” AND “Start Monitoring…” but then once I hit the “record” button, and am done recording, the soft play through of whatever I was playing turns off, and I have to go back to select “Start Monitoring…” each time so I could continue to listen to whatever signal was coming into the computer. This is a pain and I just want to have a continuous “always on” for the input signal.

How do I fix this?

I have tried searching all over the internet for solutions to these problems for hours and have gotten completely irrelevant search results.

Can you help?

Have you looked in the Manual for the Mac? Some Macs had one connection which would do both stereo line in and line out by switching. Choose Apple (upper left) > System Preferences > Sound. You will see a drop-down menu “use audio port for: ” Drop this menu down and select “SOUND INPUT”.

Mic inputs are usually mono, so probably your “adaptor” is for mono input and you are getting what you paid for. We can’t tell you unless you give the make and model number of the adaptor.

If you want a USB interface with a decent quality line level stereo input (for signals that have already been amplified), see Missing features - Audacity Support .

Correct, if you want to listen without recording. We don’t allow “monitoring always on” because it is buggy. So unless you had an early 1.2.x that had monitoring always on before we pulled it out, I’d have thought any 1.x versions that had software playthrough would also require you to monitor in order to listen without recording.

Mac’s used to have hardware playthrough but that was in the days of OS X 10.2 or before.

Try LineIn here: Rogue Amoeba | What can we help you find? .


I was using a Plantronics 770 USB audio adapter. Apparently it does only mono… this was a surprise to me because on and off for 10 years I had been using adapters and never recalled “mono” being an issue, so I’m still in shock that it doesn’t give me normal stereo input.

I saw that the Griffin iMic does normal stereo audio in to USB, so I’ll order that and see if it works.

I have another question:

How can I make the waveform thicker in the Audacity display window? I tried searching all over the internet by putting “Audacity waveform thickness” into a general search engine and got not one single relevant result. How do I make the waveform thicker?

Yes. It is for connecting a microphone to a computer: .


Please start a new topic for an unrelated question. I have answered that here:
How do I make the waveform thicker? .


Please start a new topic for an unrelated question. I have done this for you and replied here: How to extend the window to get spectrum of lower frequencie .