The Aplication failed to initialize properly [SOLVED]

I have just reinstalled audacity on my XP computer.
The older Version of Audacity run perfectly ,
but as I have suggested some friends to use this program
to convert Cassette tapes to hard drive and or CD/DVD.
Thought I had better have the same version that they are using.
I did a uninstall of the older version before installing the latest version,
I did forget to get it to reset the settings when I reinstalled it.
Any Ideas of what is wrong and how to fix it
The computer is running
XP Hopme edition

hoping some light may be sheed


How old is your computer?
If it is more than 12 years old, it may not have SSE2 ( which is required by Audacity since Audacity version 2.0.6.

Please also note:

I Had an earlier Version of Audacity installed before.
i think it was 2.0.??, it ran perfectly.
I used an old laptop running XP in the lounge
so only used this one for Spoken tapes
as the player I used in the office wasn’t really up to playing music.
I only upgraded this computer’s audacity so I had the latest version to guide the people I put on to it.
I installed the latest version of audacity and used the EXE version

Hamilton NZ

Reread the answer to the first post, and it jogged some brain cells,
Remember now that had trouble with the install on this computer the first time,
Checked my tecko journal and I had to uninstall Audacity, delete the folder
and then install an earlier version of audacity resetting the settings.
This worked again the same as the first time

Strange that!!!