Suddenly I can't export a file and save as MP3

I’m a voice over artist who is recording in Audacity and then exporting and saving the file as an MP3. I used to be able to do this fine but now I receive the attached message. It’s telling me that I have to download LAME, which I have done. Audacity is not reading the download though for some reason. Can someone help, please. Frustrated!
Screen shot 2012-09-18 at 1.18.20 PM.jpg

It’s probably not “suddenly.” You changed machines or did an upgrade or made some other relatively major system change like that. A change from Snow Leopard to Mountain Lion causes all sorts of problems because ML hides the system folder and SL doesn’t.

You could also have tried to do a cold install of Audacity or reset the preferences files.

I’ve had problems with lame under Mac-OS as well and I would need to go back in to the notes to figure out how I solved it. I’m bringing up a new machine with Mountain Lion and I’m sure I’m going to have the same problems – maybe in addition to the Leopard ones.


Can you get to the folder indicated with Go > Go To Folder > and then type the pathway name?

If you can’t get to it manually, then that’s the problem Audacity had. More as we find out.


Did you “update” OS X?

Quit Audacity.

In Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg in Text Edit and remove all the content then add


Save audacity.cfg.

Follow the steps here:

to download the zip of LAME, extract the libmp3lame.dylib file somewhere other than /usr/local then locate that file in Audacity’s Libraries Preferences. You could instead extract the libmp3lame.dylib into the same folder that you run Audacity from. Audacity should then see LAME without you having to locate it.


I am using the same operating system I used months ago, when things were working fine. I do however, have my computer set up to do automatically do new updates.

Automatic Updates typically does security updates and bumps you from iTunes .0003 to iTunes .0004, and adds functionality to one of the BlueTooth tools. Housekeeping stuff like that.

Sliding between major operating systems is not generally an “update.” Particularly not when they can get you to pay for it.

We’re dancing around suggesting something serious wrong with your machine. Mac-OS doesn’t just lose files and settings.

Go > Utilities > Disk Utilities > select your system drive and Verify. That should grind for a while and give you a green clean bill of health.

The volume Macintosh HD appears to be OK.

Were you able to navigate to the folder Gale called?

Just to do it, while you’re in Disk Utilities, how much room do you have left in your System Drive? A Mac can become unstable if you start to run out of room.


It is also possible that Repair Disk Permissions in Disk Utilities will help, because it is most likely a Mac permission problem that is preventing Audacity using the dylib file.

However if you follow you won’t need special permissions to call libmp3lame.dylib from your Desktop or Audacity applications folder. You might be able to put the dylib file on your Desktop and browse for it in Audacity without finding and editing audacity.cfg but it would be better if you could edit the audacity.cfg. file as suggested.