Still, 1 bug in Tags for export

win 7 Audacity 2.3.2

Hi. As I mentioned in Adding Features/FMPS_RATING

if I load the custom Template I made in previous Audacity, and click ‘make default’, it keeps loading the unmodified Template.


still a bug [‘set as default’ doesn’t work].

Please post the template file so that we can try to reproduce the problem.

t1exp.xml (91 Bytes)

I’ve tested loading that template, and setting it as the default, in Audacity 2.2.1, 2.3.1, abd 2.3.3 alpha. In each case it worked as expected.

Please take me through, step by step, how to reproduce the problem.

I export a song, so write its name, then tags window appears,
I load this (or other template, or create a new one),
push ‘set default’ button,
save the song (changing maybe the ‘Genre’, maybe the ‘rating’, maybe letting ‘experim’ and rating ‘0.1’ unchanged),
when exporting next song, when tags window appears it never loads the supposed default set by me, but:
a if the song comes with it’s own tags, those appear.
b if the song doesn’t have any tag, the regular Audacity rows appear (so without ‘FMPS rating’)

Always exporting to Ogg, Audacity 2.3.2 in portable mode (official way, no ‘portapleapps’ version).

Are you exporting the entire project?

Where does this “next song” come from?

Not exporting the entire project, just the edited song to ogg.

“next song” come from: wherever, either if it’s an mp3 an acc, from a cd or whatever, different songs from different sources. Some come without any tag (checked in Foobar), the ‘set default’ Layout in Audacity never loads (automatically, so i have to click ‘load’ and choose a saved one).

[and i would like even on songs with tags, to have a row for rating to appear always; that’s the feature request in ‘FMPS rating Tag on export’ ]

So if you set a custom template as “default”, then open a new project (“Ctrl + N”), then open the metadata editor in the new project, do you see your custom template?

no, open a new project (“Ctrl + N”), then open the metadata editor in the new project, i don’t see my custom template.

but now i see a [bad] way in which it loads: saving the project [before i never saved projects]. In this saved project the custom template loads, but this route implies extra clicks [delete the just edited song, delete the history items, then open the new song] actually manually loading the custom template is fewer clicks.

[after this way of making ‘custom template’ work, ‘open a new project (“Ctrl + N”), then …’ still doesn’t load my custom template]

So, ‘set default’ should work without having to ‘save project’.

I’ve just tested with Audacity 2.3.2 on Windows 10, and it works for me, which suggests that we are missing some important detail.

Please take me through, step by step, how you set “t1exp.xml” as the default.

I was going to say: ‘win 7’, but found out the reason:
previously i was doing the process of …push ‘set default’ button,… during the exporting of the song, with last step being clicking ‘OK’.

What works is doing the same but not during the exporting of the song, but doing it apart, opening Edit/metadata, then doing the same … > OK; now default is saved.

So solved thx, and please consider the request Adding Features/FMPS_RATING because if the song comes with it’s own tags [in which case if one loads the ‘Default’ -or other Template- manually, the existing tags dissapear…] it is very bothersome to have to for each edited song:

  • create a new row >
  • add the name FMPS_RATING for it >
  • write the rating, a number 0._ [0.1 is shown as ‘half a star’, 0.2 as ‘a star’, … in programs like Amarok and other audio players.]

Well, it remembers the new ‘Default’ up to crt+N, as soon as a new song is added, it loads the same old Template without ratings row. It seems even if the song has no tags, Audacity anyway loads ‘empty’ tags from the song forgetting the ‘set default’ previously OKayed.

So the Adding Features to Audacity request would solve all cases.

That is not clear enough for me to be able to reproduce what you are doing. Please take me through this, step by step.

‘set default’ is remembered:
a if one ‘save project’ = useless, means extra steps
b what you have been doing: click ‘Edit’, click ‘Metadata’ ect = useless: after the ‘set default’ Template is indeed ‘remembered’, add a mp3 and see that the ‘set default’ is lost when adding a song, it is only remembered with a '‘virgin’ or ctr+N project [or for recording or something but not when adding songs]

‘set default’ is not remembered:
Don’t click ‘Edit’, click ‘Metadata’ ect but:

  • add an mp3 with or without Tags
  • File > ‘export as Ogg’
  • wrte a name for it, ok.
  • tag editor appears, do the rest. [save a template or load mine, click ‘set default’ , click ‘Ok’]
    = ‘set default’ is not saved.

OK, I see. Default metadata cannot be set during Export Multiple.
Of course the workaround is very easy - just set the default metadata before starting Export Multiple.

I agree that either the “Set Default” should either work in this case, or be greyed out so that it is clear that the button has no effect.
This is now logged as a bug.

I was not talking about ‘Export Multiple’ but just ‘export as Ogg’ [unless is the same idk]

he workaround is very easy - just set the default metadata before starting Export Multiple

No, as i said, “add a mp3 and see that the ‘set default’ is lost when adding a song”

idk why you keep not being able to replicate or getting what i’m talking about, maybe you ticked long ago in the ‘don’t show this again’ in the Tag Editor, so it’s not opening automatically for you when exporting a song as Ogg.

OK, then please provide step by step instructions for how to reproduce the issue. Given that there are millions of Audacity users, I’m surprised that this is causing so much trouble for you.

the ‘step by step’ already given, many times,
so if my English is not good for you, make your own Template, set it as default by your own method, then:
“add a mp3 and see that the ‘set default’ is lost when adding a song”
steps for this? :
[you have supposledy already set a default]
type crt+N
drag an MP3 into Audacity

  • Click File then Click ‘export as Ogg’
  • in the little window that appears where you chose where to save the song write a name for it, then Click ok.
  • the tag editor automatically [here, i haven’t ticked ‘don’t show this again’ ] appears,
    *see that your previously saved ‘set default’ is not there [problem 1].
    *as an aside [problem 2], now try to save another Template as default [ Click ‘set default’ then Click ‘Ok’ , or by your own method, if it’s other ]; = ‘set default’ is not saved.

I’m surprised that this is causing so much trouble for you

you always assuming the problem is me right? yeah, or i didn’ wrote enough ‘step by step’ , incredible.

Yes, my template is overwritten, but only if the imported file has metadata. This is the expected and documented behaviour.
If the imported file has no metadata, then my template is there.

I’ll now try your more detailed instructions and write up my results in a new post.