[SOLVED] Audacity can't play audio on Fedora 32

I am on Fedora 32.
Linux Kernel: 5.6.11-300
Installed Audacity from: Gnome Software (so probably a flatpak)

When I hit play on Audacity it fails with:

Error opening sound device
Try changing the audio host, playback device and the project sample rate

I have the following audio devices listed beside the small speaker sign on top right hand side:

  • HDA Intel PCH: HDMI 0 (hw:0.3)

  • HDA Intel PCH: HDMI 1 (hw:0.7)

  • HDA Intel PCH: HDMI 2 (hw:0.8)

  • HDA Intel PCH: HDMI 3 (hw:0.9)

  • HDA Intel PCH: HDMI 4 (hw:0.10)

  • hdmi

The “Audio mode” is to:

What do I do ?

I am pretty sure Fedora uses PulseAudio rather than ALSA.
Is that what is causing the problem ?

Run the “Audio Device Info” and save the info somewhere convenient, then attach the “deviceinfo.txt” file to your reply.

Here is my Audio Device Info. And please note that this problem is with Audacity only. VLC, Firefox and everything else can play audio fine.
audio_device_info.txt (4.34 KB)

PulseAudio is a software layer between ALSA and applications, but yes I would have expected Fedora to use PulseAudio.
Surprisingly there is no sign of PulseAudio in the Audio Device Info.

To check if PulseAudio is installed, run this in a Terminal window:

pulseaudio --version

$ pulseaudio --version
pulseaudio 13.99.1-rebootstrapped

So now what ?

Is there no solution ?

OK, so pulseaudio is installed.

What happens if you run:


$ pavucontrol
bash: pavucontrol: command not found…

Should I install it ?

“pavucontrol” is the “PulseAudio Volume Control” and is a standard part of a PulseAudio setup. It may not be strictly “necessary” on all systems (you may have some other volume control available), but it is a useful tool, and probably the best volume control when using PulseAudio. In short, yes I think you should install it.

I don’t use Fedora myself, but you may find this article useful: Releases/FeaturePulseaudio - Fedora Project Wiki


I just want to know if this a problem with Audacity or Fedora.

Who should I contact for this problem ? Audacity devs or Fedora ?

I went through the link, but it did not prove to be useful. I think this is a problem with Audacity itself since I have no problems with sound on Fedora otherwise.

Just point me in the right direction. I have no idea what is going wrong where.

I had pretty much the exact same problem, and I just stumbled upon this solution.
I uninstalled Audacity through Gnome Software, and then installed it with dnf.

sudo dnf install audacity

It works fine for me (for now :wink:).

Yes this is exactly what I did and it worked for me.

Thanks for posting your solution.
Which version of Audacity does that install?

create /etc/modprobe.d/default.conf with this content:

options snd_hda_intel index=1

Then reboot.

Finally working!!

// Fedora 32, Lenovo & amd

$ lspci -knn|grep -iA2 audio
04:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller [1002:15de]
Subsystem: Lenovo Device [17aa:3810]
Kernel driver in use: snd_hda_intel

04:00.5 Multimedia controller [0480]: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor [1022:15e2]
Subsystem: Lenovo Device [17aa:3814]
Kernel modules: snd_pci_acp3x, snd_rn_pci_acp3x
04:00.6 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller [1022:15e3]
Subsystem: Lenovo Device [17aa:3813]
Kernel driver in use: snd_hda_intel