Recover .au files (no .aup file)

I migrated all of my recordings by zipping them up and moving them from my old ubuntu computer to a new win 7 computer. The zip file was somehow corrupted. I used a zip repair software and everything was recovered EXCEPT the .aup files for each of the projects. I have all or most of the .au files for most of the projects. I’ve been reading and following all of the tips here:

However, the issue that is thwarting me seems to be the order of the .au files. All of the files are named “e000” + three seemingly random chars. I’ve tried multiple programs/scripts to sort by “date modified” and the batch renaming them to “b00001, b00002,…,b000nn”. No matter how I sort them, the final product is all mixed up. The utility by Tyler Knott seems to work the best but requires me to rename all of the .au files in the original order so the concatenation can work. How can I find the original order?

I will try also to move the zips back to a ubuntu or *nix system and see if unzip reveals the .aup files. Please refrain from “but don’t you have a backup or copy?” posts. Sorry, all i have the .au files.

What were the Audacity versions?
Did the filenames have any magic characters? Any $ or # or extra dots or slashmarks? Characters acceptable in one OS may be poison to others.

Unfortunately, I am unsure of the audacity version on the previous computer - it was Ubuntu and was installed perhaps last spring. Was there an audacity version 2.x for Ubuntu then? The filenames have no strange characters - all alphanumeric.

Screenshot of filenames attached. Any way to order them correctly so can stitch them together using the recovery tools?

I guess the real mystery is: why aren’t the .aup files recoverable from the .zip of 20+ audacity projects that were migrated from the ubuntu machine? I am currently transferring the .zip to another ubuntu machine to see if the .aup files can be recovered from the .zip file. Otherwise, I am stuck with the question: how do I order and rename the .au files to stitch them together correctly using “Aud_Recover command-line recovery utility” from:

No luck on the file that was transferred back to Ubuntu.

On what basis do you say the aup files were corrupted? Because Audacity won’t open them? Is it worth attaching an AUP for us to see?

Generally (in my experience) Linux and Windows won’t read zip files created on the other operating system very well if you are sending them across a network - it is some kind of encoding incompatibility. Use FTP to and from a server, or (possibly) try a USB stick.

If you need to piece together the AU files the instructions on sorting and renaming the files are in the big green box here .

So, if you are going to recover on Windows, use the instructions for xplorer 2, and then use Audacity Recovery Utility.

If you recover on Ubuntu, open a terminal then cd into the directory that contains the au files.

Then type:

mkdir "renamed" | find -type f -name "*.au" -printf "cp %h/%f renamed/%h/%TY%Tm%Td-%TH%TM%TS_%fn"|sh

and hit ENTER. This should sort the files numerically in time stamp order, so that when they are sorted in ascending numerical order (lower numbers first), the files will also be sorted in ascending time stamp order (the files that were recorded first should be first in the list).

The Audacity recovery utility cannot use those files because it wants a continuous alphanumeric sequence of files. So either:

  • Use Thunar to rename the files as they are now sorted into a continuous alphanumeric sequence and then use the Audacity Recovery Utility
  • Use the Nyquist Append Import plug-in to import the files as alternate channels.

To install Nyquist plug-ins, see here .


On what basis do you say the aup files were corrupted?

The .zip files were corrupted not the .aup files. All I have left of my projects are the .au files. I have tried many of the solutions found in the link you provided. The issue seems to be that none of the methods thus far can put the .au files in correct order. However, I have not tried on a linux machine nor via other scripting methods - I’ve only used GUI’s to order the files. What’s strange (or perhaps not) is that each windows file browser GUI i use orders by date differently. They must use different granularity. I was able to get three completely different orders across as many GUI’s even though I ordered by the same column. Go figure.

Anyway, I will try using the command you provided on a linux box and then my next attempt will be using a script of some sort, perhaps on from that page.