recording internet radio [SOLVED]

Ive got internet radio on… I got audacity up… hit record
nothing happene, no audio signal etc

anything I can do ?

thanks for help or comment

You need to select the input you want to record… By default you are probably recording from line-in on your soundcard, or from the microphone, etc.

See [u]this page[/u]. It can be tricky to record streaming audio because the settings vary with different operating systems and different drivers. If you have Win7 or Win8, WASAPI Loopback is usually the best choice.

im on windows 7

This is a list of instructions for getting your computer to record on-line content.

Self-recording is not a natural thing for computers to do, so nobody “officially” does it, and Microsoft has been making it harder and harder through Windows versions. That’s why this seems to be really hard.


I unticked that through button in audacity pref

but still no signal trying to record int radio

I went to windows sound and notices … internal microphone… along with line in etc

I enabled that and finally am getting a signal and managing to play back a recording.

very poor quality right now, way too low and theres a kind of ringing sound

at least its a start !

Please read the pink panel at the top of the page and tell us what exact version of Audacity you have.

That is probably because you have Audacity set to record from the internal microphone, which is not the correct device to record computer playback from.

Please try these exact steps. These steps require you to be using Audacity 2.0.4 or later. We recommend using the latest Audacity 2.1.0 from Audacity ® | Free, open source, cross-platform audio software for multi-track recording and editing.. In other versions the second box mentioned below may be the playback devices box and the third box the recording devices box.

  1. In Audacity, open Device Toolbar.
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Recording Device) box, choose the (loopback) input for the speakers or headphones you are using for playback. For example, if you are using “Speakers” for listening to playback, choose “Speakers (loopback)” in this step.
  4. In the third (Recording Channels) box, choose mono or stereo.
  5. In the fourth (Playback Device) box, choose the Speakers or Headphones that you are using for listening.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


im on audacity 2 0 6

cant see device tool bar

all I see is file edit view transport tracks generat effect analys help

have disabled that internal mic

When we show you text in blue, click that link to find out all the information you need.

To make sure you can see Device Toolbar, click on View > Toolbars > Reset Toolbars. Device Toolbar looks like this in 2.0.6:

NOT seeing any mention of loopback in box 2

have set as
box 1 winows wsap1

box 2 digi output devices spjf

box 3 digi output device spjf

box 4 mono recording

not seeing any red band too and fro to indicate sound is in there

I hit record… dont even get a line running … even a flat line

I try to delete the recording box thats just opened … it wont delete

I have to delete the audacity window to get out of it

( things were a lot easier with xp … )

That is expected if you are still using 2.0.6. When I wrote the steps you had not given your Audacity version.

As the image shows, in 2.0.6 the third box is the recording device, so the third box has the (loopback) choice.

If you are using 2.0.6 the choice in the third box must contain “(loopback)”. To make sure you can see the names of the devices, try dragging device toolbar wider using the handle at the right end.

Don’t choose S/PDIF for playback or recording device unless you are actually playing the internet to that device. Choose the speakers or headphones you are actually listening to in box 2. Choose the loopback device for the speakers or headphones you are actually listening to in box 3.

If you are not sure what choice to make, open Help > Audio Device Info… top right of the Audacity window. Right-click in the window that appears and choose “Select All”. Right-click again and choose “Copy”. Paste what you copied into your reply.

Obviously we assume you have permission from the broadcaster to record their internet radio.


tHANKS for the info,

Ive changed the setting s and did see the word … loop back … in box 3 , not box 2

Just went on internet radio and did a recording… Bingo it worked …

quality of sound on that little clip exellent too !