piano sounds great going in, lousy in Audacity

Good idea, Steve. I’ll see if I can sample the piano sound by itself. I’ll post it when it’s done.

Here’s a sample piano. http://www.snapdrive.net/files/372235/sample%20solo%20piano.mp3 No added EQ. I even tried just going from the L/mono by itself, out from the keyboard. That sounded even weaker.

The 1/4 inch cables are going out from the keyboard into the line-in on the mixer. One of the line-in’s is a guitar/high-imped. channel. I’ve even tried that high and low. No difference. It’s a mystery.

That sounds pretty good to me, though I don’t know what sound you are expecting. It may be that the difference/lack of quality is simply that when you are listening to the piano “direct” you are listening in stereo, but when you record, you are recording in mono.

There’s a few things that I do notice, but I don’t know if they are due to the piano, the recording, or the MP3 encoding:

  1. there appears to be some sort of gating of high frequencies (above 13.8kHz) while the notes are initially sounding. When the note has decayed sufficiently, frequencies above 13.8kHz are “switched” back on.
  2. There is a whistle at 4.5 kHz whenever notes are being played. (there are other harmonics present, but this sound the most prominent to me).
  3. There are prominent whistles at 8800Hz and 16300Hz during the “silence” before and after the piano is playing.
  4. This is not a “dry” piano sound - there is quite noticeable room ambiance - I’d guess this is due to the piano sound that you are using.
    These are all pretty subtle and I find the overall tonal quality very pleasant.

In this sample I’ve notched out the whistle from 1.5 seconds to 3 seconds. I’ve exported it as a single channel mono WAV file.

In this second sample, the first few seconds is the original and the second half has had the 4.5kHz whistle removed, the treble pushed up a little, and has been “spacialised” with a bit of reverb to make it stereo. You should notice that the stereo section sounds a lot more lively.

To recap, it sounds perfect, punchy and clear when you’re listening to the headphones, but anything downstream sounds flat and lifeless.

Is it in stereo at the mixer and mono in Audacity – I mean there may be two channels, but they’re identical?

You can get into serious trouble if you plug a mono performance in a stereo plug into a connection expecting full tilt boogie stereo. The production echo and flavor of the performance may go flat. Really odd things happen, but not if you hear the performance at the mixer and it’s OK. This can still get you into trouble if the show in Audacity is mono. Depending on how it got mixed to mono, you get get odd distortions.

Until this gets resolved, I would avoid oddball sample rates and bit depths. 44100,16-bit, Stereo is good enough for billions of Music CD listeners and 48000, 16-bit, Stereo is holding up digital television sound all over the world. Obvious problems like what you have are far worse than the difference between 48000 and 96000.

Are you on a PC? Do you like to record internet audio, YouTube, etc. Do you have Mix-Out or What-U-Hear selected in your Windows Control Panels. That can create a very slight echo and seriously change the character of stereo instruments.

Audacity applies no effects or damage on recording. It doesn’t do anything in real time except straight recording and play back. It’s a complete slave to the computer running it.

Set Audacity Preferences for Hardware or Software Playthrough, whichever is supported. Click inside one of the red recording meters and they will wake up and monitor the show without going into record. It will also send the show out the headphones for you to listen while you troubleshoot and experiment.

Koz

<<<There’s a few things that I do notice>>>

And all that could be subtle feedback problems from having Mix-Out on by accident. Or leaving the microphone and speakers running together. The computer, I think by now it’s clear, is Doing Something Wrong.

Koz

The original piano solo has very little high frequency content and sounds dull (muffled).

I added extra high frequencies using Steve’s vocal exciter

Audacity frequency analyses - Before (blue) After (purple).png
BTW Jim expect a writ from Bruce Hornsby for breach of copyright :slight_smile:

I suspect that is exactly what is happening - now waiting for Jim to confirm.

I’d go for 32bit 44100 (the Audacity default), or perhaps 32bit 48000 if that suited my sound card better. There’s no point going above 48kHz as the keyboard cuts off before 20kHz. 32 bit has advantages with processing and Audacity 1.3 will automatically do a nice job downsampling on Export.

It’s nice to know that someone is using it, but I don’t know that I would really recommend it - to my ear it’s a bit rough - written more as a “proof of concept” than a high quality effect.

Personally I doubt that is the problem on this occasion (though no harm in checking) - I think you were right the first time koz re. the sound becoming dull/lifeless as a result of going mono.

Hey Steve – that second sample with the contrasts really helps. Did you add that spacialization/verb in Audacity? Also, is there a tool in Audacity that you used to identify the noise and the way the sound spectrum should sound? Thanks. I’ve been a musician for decades, but have very little experience in audio engineering.

Thanks, Koz. The sound out from the keyboard is stereo, but is only showing up mono in Audacity. Here’s a top image of the Alesis mixer I’m using. I’m running the outs from the keys into channels 1 and 2 on the mixer. P.S. I turned off all other programs but Audacity when I recorded. I’ve also got it set at 32bit 44100HZ.

Hey Trebor – thanks for the input. Yeah----Bruce got everything he knows from me. (I’m a huge fan).

Audacity has frequency analysis: “Analyze” menu, “plot spectrum”, showing you the frequencies which are present.

Audacity doesn’t Superimpose the two frequency spectra like I did here, I did that using GIMP.

OK, well that’s one problem right there. Channel 1 should be panned hard left and channel 2 hard right. Keyboard Left should be in Channel 1.That will put a stereo show into the mixer when you advance the faders. The GTR/Line switch should be in Line.

The Phantom Power button should be off unless you need it for a very specific reason.

When you record, do you get both bouncing red light metres and a two blue waves? Do the two meters match exactly now?

http://kozco.com/tech/audacity/Audacity1_record.jpg

Your red meters may not look like that.

Koz

Yes, I used “Calf reverb” - I think the “Calf” LADSPA effects are currently only available for Linux, but there are other reverbs available for other platforms. The main objective was to restore some “width” to the sound.

As koz has indicated, the lack of “width” in the recording is because you have both the left and right channels of the keyboard panned to the middle and effectively turned it into mono.

The main tools that I used are on the sides of my head. I then used the “Spectrum View” to go looking for what I was hearing. To see the track as a spectrum, click on the track name and from the drop down menu select “Spectrum”. The resolution and contrast of the spectrum can be adjusted by tweaking its settings which are in:
Edit menu > Preferences > Spectrograms.

For deciding which high frequencies to boost, I took a similar approach to Trebor - there’s no point trying to boost something that’s not there, so forget about boosting really high frequencies because there aren’t any. I’ve got pretty good frequency recognition, but not good enough to say “that’s exactly 16540Hz”, I’d just know that it’s somewhere around 16k - but the Frequency Analysis window and the Spectrum view can help to pinpoint frequencies pretty accurately.

I think Koz has covered everything else.
How about posting a new stereo recording so we can hear what a Roland KF-90 piano really sounds like :wink:

Hey guys – you all have been really helpful. I’ll get back to the keyboard early next week to record a new sample with panning, etc. I’ll post it hear for you. Thanks again!

So a keyboard is a low-impedance instrument and a guitar is high? Thanks again.



Irish recently pointed out this freebee reverb which is rather good.

Compared with a standard microphone input, both are high impedance. The guitar input is probably higher impedance than the line input. You can usually use a guitar in a line input or vice versa without too much problem, but if you have the option to choose you should usually use the guitar input for guitars and the line input for line level devices. Keyboard outputs are usually around line level. Some guitars that have active pickups may work better into a line level input. The really important thing is that if you plug a passive guitar pickup (or other instrument) into a microphone (low impedance) input it is likely to sound really thin and if you plug a line level instrument into a microphone input it will probably distort badly because the signal level is much too high (and could cause damage).

I think I found something that might be contributing to the problem: I put in the cables out from the keyboard into channel 1 and 2 on the board – one at a time (isolating each channel by itself). With each channel, I got sound (the “clip” light illuminated, so I knew I was getting a signal.). However, in Audacity – only the left meter shows activity – the right shows nothing. It’s like it’s forcing the signal into mono.

P.S. That’s also with the left and right pans panned out.

Are you using Audacity 1.3.11 (recommended)?
If you are, go to “Edit menu > Preferences > Devices” and ensure that “Channels” is set to “2 (stereo)”