notch filter?

I’m trying to notch out one particular frequency of feedback. I tried using the Noise Removal function, but it distorted the piano sound. Here’s a sample. Is there a more precise way to get at that one annoying frequency? Thanks!

The only fault I can hear is the level of noise (hiss) is quite high,
This type of broadband noise cannot be removed with a notch filter.

Noise reduction can reduce it, (see attached mp3), but like you’ve found it will distort the sound to some degree.
You’d be better off looking at the settings on your hardware (e.g. mixer) to see why you have such a poor signal to noise ratio, rather than trying to cure the problem in post-production.

It’s a marginal difference but I think I prefer to just use the Equalizer effect and drop the 8kHz and 10 kHz sliders.

Thanks, Trebor and Steve. I’m not sure why I’m getting that particular frequency. I’m going out from the piano/keyboard into the mixer. I even made sure the levels weren’t spiking. I only get the sound when I press “Record.” Until then, I don’t hear it. (Could it be because I’m using two different cables to go from the piano to the mixer: one regular and one gold?

Thanks for the help.

no matter what the salesman said those two cables made absolutely ZERO difference in your recording unless they were different lengths and you were recording on both of them at the same time in which case i think you could get a beat freq due to the delay depending on what your pc was doing with the inputs.

but if you like, i will sell you a matched pair of red and green cables that will absolutely sound perfect and guaranteed to do nothing to your sonic signals. $8000 each, two for $15,000. guarnateed!!! :mrgreen:

Below is the frequency analysis of your “notch needed” mp3 from 0.2 to 0.4 seconds …
'notch needed' from 0,2 to 0,4 seconds.png
It shows broadband noise which runs across the entire spectrum form 20Hz to 20,000Hz.

It is not one “particular frequency”: it’s a band of frequencies 20KHz wide,
slighly worse at higher frequencies ( hence Steve’s suggestion to cut 8-10Khz ).

Notch filters remove a narrow band of frequencies, typically a few Hz to a few tens of Hz wide,
so would be quite usless at removing this broadband type of noise.

I suspect the volume on the piano is too low or the piano level on the mixer is too low,
I would suggest turning them both to middle values and turn down the master output level on the mixer.
The result should be a better signal to noise ratio, i.e. less broad bandnoise, a.k.a. hiss.

I’m wondering if you are hearing something which we can’t hear - a frequency that is not present in the recording, but is present in your headphones.

Are you recording on a laptop computer? If you are, try disconnecting the power supply and run it on batteries. Do you still hear “that particular frequency”?

Are you talking about that rain-in-the-trees hiss sound behind the piano?

Anything we do in post production is going to leave scars. You can suppress the high pitch tones and take some of the edge from the sound, but that will also take the sparkle out of the piano. Noise Reduction, as you found, is helpless in the face of hiss. Noise Gate is good, anything below a certain volume goes away, but that will slice the tails from the notes.

…I only get the sound when I press record…

That Voice in the back of my head is screaming that’s important…but I can’t think how.

Describe the electronics. Go crazy. Pretend you want me to go to West L. A. Music and buy your exact system. What kind of microphone, etc?

One gold cable is not going to make any difference unless you live next to the sea and suffer from corrosion problems over years of use. The length won’t make any difference either until you get to the multiple mile sizes. All these problems are electronically real, but only in extreme use, not likely for someone trying to record a Bösendorfer.

Where do you plug your headphones? You do use headphones, right?

Once we solve the recording problems, we’re going to want you to describe how you placed the microphones for your performance. That part seems to work really well. I found myself thinking this would be very cool without that stupid hiss.

That probably occurred to you, too.


I don’t hear (or see) anything that I would describe as “that particular frequency”. The only noise I notice is “that hiss”.
Which makes me wonder if you (Jim) are hearing noise from your computer (power supply noise/disk noise or similar) that is not being recorded.

You can suppress the high pitch tones and take some of the edge from the sound, but that will also take the sparkle out of the piano.

And I haven’t actually tried this, but I’m betting the music is too quiet or the hiss level is too high for the noise gate to be effective.

Do you have ‘Play Tacks While Recording New Ones’, ‘Software Playthrough’ or ‘Hardware Playthrough’ selected in Audacity Preferences? Turn them all off or deselect them and restart Audacity. Still hear it when you press Record?


Amplify the track to 0dB then try these settings with the Noise Gate (latest version available here: )

Gate (Link stereo)
Gate Frequencies above: 8000
Level Reduction: -9
Gate Threshold: -9
Attack/Decay: 1000

This will cause the gate to gently ride up and down with the dynamics. The very high frequencies on the piano are only present for a short while as the hammers hit the strings, when the gate is open. When the gate closes, it attenuates frequencies above 8kHz. It’s not perfect, but it retains the sparkle of the piano (and some noise).