No module found

Hello everybody. :slight_smile:
I would like to use mod script pipe for some (simple) automation, now that it is included in the default audacity build, however when I open the Preference → Modules window, the module is not shown (see screenshot. Sorry it is in french, but : « Aucun module trouvé. » means « No module found. »). I tried this with Audacity version 2.3.2 (from the default Ubuntu PPA), and now from version 2.3.3 (from this PPA, and got the same problem with both versions (I double checked each time in the Help → About Audacity window that I really was running the expected version).
So I am puzzled, and found nothing in the documentation to explain.
Capture d’écran de 2019-11-26 16-34-04.png

For Linux, we release the source code and it is left for the Linux package maintainers to build the binaries (the executable program). We cannot guarantee that they build the provided modules or the manual. I am currently rewriting the build instructions for Linux, which will hopefully encourage the Linux package maintainers to build the modules as well as the main Audacity binary.

My guess is that the PPA build does not include the scripting module (they’ve not built it).

Also, modules may not work with Snapcraft or Flatpack builds.

Oh, I thought it would be included by default, my bad.
(And I have removed the Snapcraft build from the last time, haha. I’ve replaced it by the « official » Ubuntu package. ^^)

In that case, is there a (relatively simple) way for me to build just mod script pipe, and add it to my Audacity install, without having to build the whole Audacity project ? (and its dependencies)

Unfortunately no. To be compatible, modules need to be built on the same day as Audacity.
However, building Audacity is not particularly difficult. Most of the dependencies are available from the Ubuntu repository, and those that aren’t are included in the Audacity source code.

I should have the updated instructions complete this week. Feel free to nudge me if I forget to get back to you.

Well, I’ll wait for the updated instructions in that case.
Thank you for your answers. :slight_smile:

Updated instructions here:
Let me know how you get on.

Hi Steve,
Thank you for your hard work on the linux build instructions.
I am having an error that I cannot resolve:
During …/configure (with your suggested options) I get the following error:
configure: WARNING: Libtool does not cope well with whitespace in pwd
checking build system type… Invalid configuration source/audacity-minsrc-2.3.3/build/../lib-src/portaudio-v19/include': machine source/audacity-minsrc-2.3.3/build/…/lib-src/portaudio’ not recognized
configure: error: /bin/bash …/…/…/lib-src/FileDialog/autotools/config.sub source/audacity-minsrc-2.3.3/build/…/lib-src/portaudio-v19/include failed
configure: error: …/…/…/lib-src/FileDialog/configure failed for lib-src/FileDialog

This is on Pop-os 18.04 (essentially Ubuntu 18.04) using Ver 2.3.3 source .

I tried an install from a PPA but I need the mod script pipe that is not available there.

Please try this:

  1. Delete your “build” folder
  2. Create a new build folder
  3. In the new build folder, run this configuration command:
../configure --with-lib-preference="local system" --with-ffmpeg="system" --disable-dynamic-loading --with-mod-script-pipe 2>&1 | tee build-log.txt

That will create a file “build-log.txt” in the build folder.
Attach the build-log.txt file to your reply.