Loss of quality using EQ

I’m quite experienced with using Recording and editing software, but this one has me buffaloed. I’m using 2.0.2 (recently updated to 2.1.0 but that has not been checked. I import live recordings, break them into tracks, and edit for quality. Generally all that is done is eq and normalize in that order. Tracks are frequently under recorded, so sometimes I need to amplify a bit before doing anything else. What happens is this: applying EQ results in an audible loss of quality of the recording. I’ve been avoiding the issue by cutting up the tracks and then importing to other software to eq and normalize. Under those circumstances there is no loss of quality. Now I need to record 5 tracks, edit, and mix down. My other software doesn’t seem to allow any multi-track (beyond stereo) selection and playback and so is useless. Audacity is wonderful…if the loss of quality when eq is used can be overcome.

I’ve read a couple of reviews that imply that the effects in Audacity do not always work cleanly. I’m hoping that is not the case.

Any thoughts? Thanks,

Chuck Boody

The current version of Audacity is 2.1.1 and is available here: Audacity ® | Free, open source, cross-platform audio software for multi-track recording and editing.
Baffling indeed - no loss of quality here.
In what way is the “quality” reduced?
Please provide exact steps so that I can try to reproduce the issue. Also, I’m guessing that you are using some version of Windows?

“Noise Reduction” type effects (in all software) are always vulnerable to sound quality issues. The trick is to use as little noise reduction as possible.

The “Leveler” effect in Audacity was originally introduced as a quick and dirty (very dirty) method of reducing dynamic range. It is not recommended for high quality work, other than as a “distortion” effect.

“Time stretching” effects tend to change the sound quality (in all software), particularly when stretching a lot. Audacity includes several time-stretch type effects, “Change Pitch” and “Change Tempo” are relatively simple effect - easy to use and process quite quickly. They use the SOLA algorithm which tends to work best with non-percussive type sounds. Audacity also has a “Sliding Time Scale / Pitch Shift” effect, which is somewhat more complex, using the SBSMS algorithm. This effect processes quite slowly due to the more complex algorithm, but in most cases will produce noticeably better sound quality.

Other effects in Audacity should all provide extremely high sound quality.

I downloaded 2.1.1 before writing you, but it fails to work on my machine. The program opens and immediately closes again. There is an error reported the first time you try, but it flashes by so quickly that I can not read it. That’s why I’m using 2.1.0.

My machine is a iMac 27 inch from mid 2011 with 8 gig of memory. Running OS X Yosemite 10.10.5 I have not upgraded because the new system is likely to break some (many?) of my programs.

I do not use “Leveler,” “Noise reduction” or any of the “stretch” type effects. It is easy to see how they could cause issues. As I said in my original post in addition to setting regions all I usually do is EQ and normalize. Occasional “amplify” or reverb. Care is taken to avoid clipping. The resultant sound does not have the clipping distortion.

You should be able to duplicate what I do by taking a stereo track, and using EQ. below 250 cycles is often raised as much as 6db. area from 250 to about 2000 cycles is lowered as much as -4 db, area above 2000 hz may be raised as much as 6 db. Care is taken to avoid clipping and this is done before normalization where there is plenty of headroom. If you apply and then A-B test by removing and replacing the eq the EQed sound has a sort of “dead” quality as though something is damping everything. It is not quite the same as rolling off all the high frequencies but it is similar. It is not my ears. In a blind test my wife consistently identifies the EQ version as “worse.” If you burn a CD that quality change continues to be audible.

I have not tested this issue with 2.1.0, but will try to find something I can use to test it in the next few days and let you know if the problem exists. The whole matter puzzles me, since I do not recognize what the change is (as I would with clipping), and I can see no rational reason for the change.

I don’t use Mac, but perhaps that’s the “Gatekeeper” problem described here in the FAQ: Audacity Manual

I can of course hear the difference after applying EQ (there would be no point applying it otherwise :wink:) but I don’t notice any quality loss. In fact, the Equalization effect is ‘almost’ reversible if you “Invert” the curve that you have applied (click the “Invert” button) and then apply the inverted curve. (it is not absolutely reversible because the inverse filter will never “exactly” match the original filter, but it is pretty close and the difference is virtually inaudible). Setting a very large filter length may produce a small amount of “ringing” on transients, but that should not be noticeable with the default filter length. The filter length is a compromise between time resolution and frequency resolution. Large filter lengths provide higher frequency resolution, while short filter lengths provide better time resolution - normally a mid-way setting works best. For high quality audio I generally set the filter length to a bit less than half way (around 2000).

Rule #1 with eq’s: don’t raise levels, cut.

Eq’s are supposed to be like a surgeon’s knife, not a butcher’s hatchet.

If you need to amplify the 250 Hz band, that is usually because something in the mids is too loud. Find that frequency and attenuate it.

I don’t know which eq you used, but a parametric eq will usually work better for this kind of surgical work because you can make the band narrower if needed.

BTW, El Capitan won’t break your audio software, or any other for that matter, but it will almost certainly break USB. Apple has decided, in it’s infinite wisdom, that USB ports will power down when putting your machine to sleep. I can see the sense for laptops, but they even do it on imacs, mini’s and -grasp- the Mac Pro. The same code change means any older USB device that isn’t following the book by the letter, will fail. Not only audio interfaces, but scanners, printers and even harddisks…

We’ll have to wait and hope for 10.11.2 to bring a fix.

While testing, I hadn’t noticed since my main interface is Firewire and the USB interfaces I tried all worked. That is, until the machine went to sleep…

Thanks to you both. I’ll look at the “Gatekeeper problem.”

Cyrano, I know one should generally cut levels, but the sources I’m working with are so under recorded that boosting makes the better sense. Parametric EQ does not work as well for these recordings, since they are of full concert band of 50 or so pieces.

Thanks for the update on USB. I’ve a mix of firewire and USB hard drives. I think I’ll wait a bit…

Checked “gatekeeper” that is not the issue, I do the fix all the time for many different programs.

It’s a now-fixed bug in 2.1.1, triggered by previously using an older Audacity version.

See Fix for Audacity 2.1.1 not launching.


Gale

Thanks Gale,

That solved loading 2.1.1 Now I can check the sound quality issue with up to date stuff!