I have no sound in PC speakers from a cassette player by USB

Wiindows 7 x64. Audacity 2.1.2. Exe file.
I bought a cassette player for digitizing cassette recordings on a PC. It is connected by a USB cable with an USB2 port on my PC. When I connected it, the computer recognized the device and wrote “The device is ready to use”. The cassette player gives sound through my head phones plugged into its 3.5 socket. I unplugged the headphones. My PC speakers give sound from every other programs running in my computer. I opened Audacity, as advised in the instruction to my cassette player, went to Edit → Preferences → Devices and set:
Host: MME
Playback device: Speakers (Realtec High Definition)
Recording Device: Microphone Array (2-USB PnP Audio)
Channels: 2 (Stereo)
In Recording menu: checked “Software Playthrough”.
I apply 2 screenshots.

Host “MME” was not mentioned in the instruction to the cassette player, this instruction shows a screenshot of another version of Audacity with another interface, I don’t know which, I first installed Audacity from the CD that was attached to the device when I bought it, it has exactly the same interface as 2.1.2. I don’t know what is MME but if I change it to another option, then the other “Devices” menu options automatically change to what is not advised in the instruction. There is no sound anyway. What should I do to get the sound??
Audacity Recording settings.png
Audacity Devices settings.png

It is correct to set the Audacity playback device to your speakers. If you choose that speakers device, the speakers volume must be turned up in Audacity, and unmuted in the system.

If you want to hear the cassettes while recording, enable Transport > Software Playthrough in the Audacity menus. If you want to hear cassettes without recording, click in the Recording Meter where it says “Click to start monitoring”, as well as enabling Software Playthrough.

This page in our Audacity Manual will help: Recording with USB turntables or USB cassette decks.


Re-check to make sure your speakers are still selected as the playback device… Sometimes when you plug-in a USB audio device Windows sets that “new” device as the default recording and playback device (even if your USB cassette deck doesn’t work as a playback device).

Are you recording? Is the [u]Recording Volume[/u] turned up?

Are you seeing activity on the [u]meter[/u] and are you seeing the waves develop as you record?

Thank you very much. All I needed to do was Click to start monitoring. What is “Transport” I don’t know, my menu doesn’t have, but I set Software Playthrough in “Recording” section already yesterday.
Didn’t yet try digitizing but at least I have the sound in speakers. :slight_smile:

The Menu Bar is near the top of Audacity. Software Playthrough in the Transport Menu is the same as Software Playthrough in Recording Preferences, but if you want to turn settings on and off a lot, it is easier to use the Transport Menu.

For example if you ever want to record songs playing in a web browser, you must turn Software Playthrough off.