Failed to open database file error


I’ve been editing podcast audio in Audacity, and all my .aup3 files are now giving me a “Failed to open database file” error when I try to open them. I am using Audacity 3.0.5 on Windows 10 64-bit. Is there anything I can do to recover my files? I’ve attached a screenshot of the partial error message.


All of them? Where are they located?

BTW, if you click on the white center of your error screen, then do Ctrl-A (select), Clrl-C (copy), you can then Ctrl-V (paste) the details of the error message into your forum report.

If this happens with all of your .aup3 files and you have tried rebooting, reinstalling Audacity, and resetting your configuration, it is possible that you are having a “sqlite3.rc”: “14”,“sqlite3.context”: “DBConnection::ModeConfig” error, reported by previously by a user. See also: Failed to open database file

In that prior I recommended these three (3) steps:

  1. Run Tools > Reset Configuration

  2. Uninstall all versions of Audacity, and then Install Audacity 3.0.4[now 3.0.5] from Audacity ® | Downloads

  3. It may be worthwhile perusing these forum posts that also reported a sqlite3 error 14:
    Project saved will not reopen or allow export of audio file
    Unable to open AUP File Between PCs - #11 by SirenAria
    Error; Cannot open a new empty project [SOLVED]
    Audacity is unusable

We never did hear back from that user, so please keep us filled in…

Perhaps someone else and/or the prior user will chime in.

I will try your suggestions. Thanks! Here’s the full error message in the meantime:
“timestamp”: 1633358949,
“event_id”: “f9baed82139cf847aa2ebb6fbbf321a1”,
“platform”: “native”,
“release”: “audacity@3.0.5”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.18363”
“exception”: {
“values”: [
“type”: “Error_Opening_Project”,
“value”: “Failed to open database file:\n\n\\”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “10”,
“sqlite3.context”: “DBConnection::ModeConfig”,
“sqlite3.mode”: “PRAGMA .busy_timeout = 5000;PRAGMA .locking_mode = SHARED;PRAGMA .synchronous = NORMAL;PRAGMA .journal_mode = WAL;PRAGMA .wal_autocheckpoint = 0;”,
“log”: “09:49:09: DBConnection SetDBError\n\tErrorCode: 10\n\tLastError: Failed to set safe mode on primary connection to \\\n\tLibraryError: disk O error\n09:49:09: DBConnection SetError\n\tErrorCode: 10\n\tLastError: Failed to open database file:\n\n\\\n\tLibraryError: (10): disk O error\n”

So you are getting an error code 10 which is different that the 14 of the other user. Unfortunately, neither error code tells us a whole lot.

(10) SQLITE_IOERR result code says that the operation could not finish because the operating system reported an I/O error.
(14) SQLITE_CANTOPEN result code indicates that SQLite was unable to open a file.

The error codes can sometimes refer to logic errors and are not necessarily indicative of a hardware fault or an actual database error.

You didn’t say where your files were located…

My files are located on my hard drive. Documents\Audacity\ to be specific. Does the file location make a difference?

I’m still getting the same error after uninstalling and reinstalling Audacity.

I am thinking yes - if you are having the same problem with all of your projects. Perhaps the files are being stored locally, but the operating system has compressed them or has archived them to the cloud. Maybe you do/did not have permission to access them.

On the other hand, if the problem just lies with one file, you can send to me and I’ll take a look and see if I can open it. See instructions elsewhere.

You did try rebooting your machine…

And you did run Tools > Reset Configuration…

I am having the same problem with all my projects. It started with just one project, and then over the course of a few days, I was getting the same error on all 4 project files. Nothing has changed with my permissions, I didn’t move any files around, and my OS shouldn’t be saving or archiving anything to cloud.

I appreciate your help! At this point, though, I’ve lost weeks of work, and I don’t see a way to recover the projects I had in progress. I can start over with my original audio and re-do all my editing, then export to MP3 instead of using an Audacity project.



So am at a loss. Do you ever have multiple projects open at the same time? Perhaps there are others who know what is going on or have other ideas.

If you care to, you are welcome to zip up and upload one or two projects to a file sharing service such as dropbox or google drive. PM me the link and I’ll let you know what I see.