Evening out the volume on a playlist

As Steve said, it works in iTunes, but the songs don’t get changed.

If you need to make a long playlist, you could have a look at Mixxx:

http://mixxx.org/

It’s open source, free, available for Windows, Linux and Mac and has a lot of built-n features that are meant just for your application. And it uses the iTunes library. I don’t know if it uses the volume correction, but it’s worth trying it out.

Cyrano,
Thanks for the Mixx tip. I have downloaded it and taken a quick look, and it does seem as if it may do what I want it to do. However, as I have so much time already invested in Audacity, I am going to follow Steve’s recommendations today and see where I get.
Bob

No, the other way round. If you try doing that then it is very likely that you will push some of the quieter tracks into distortion.

The way to do it is to first “Normalize” all of the tracks to 0 dB (> Normalize - Audacity Manual> ). You can process all of the tracks at the same time if you “Select All” (> http://manual.audacityteam.org/man/auda > … ction.html) and then apply the effect.

Then find the quietest track. Because you have brought all of the tracks up as loud as they will go without distorting, this track cannot go any louder. So now you need to reduce the level of other tracks to match this level. To adjust the level, use the track Gain slider (> http://manual.audacityteam.org/man/audi > … .html#gain)

All tracks have been normalized.

I tried to find the quietest track by going to View>Mixer Board and selecting all the tracks and playing them simultaneously. With the volume off - sounded nicer that way. Then I looked at the peaks registered on the meters and found one track lightly quieter. Yet when playing it solo, the output at the top of the Audacity window showed it to be just as loud as anything else. Is there a better way to determine relative volumes? Doing over 70 tracks by ear is not feasible.

Bob

Screen Shot 2016-08-03 at 12.44.39 PM.png
This happened as I blundered around trying to learn the program. How do I reverse it?

Bob

Looks like you have “scrolled” over the track’s vertical ruler. It can happen quite easily by accident if you have a mouse with a scroll wheel (or equivalent).
See here for the scroll / zoom gestures: Audio Tracks - Audacity Manual

The quickest way back to “normal” is “Shift+Right Click” over the vertical ruler.

If you normalized the tracks, then they will all have the same maximum peak level - that’s what normalizing does.
Peak level is NOT the same as “loudness”. Loudness is subjective, not an absolute measure. The only really accurate way to determine whether one track is louder than another is to listen to them.

Listening is the best way. Because loudness is a matter of how we “perceive” the sound, it is the only really “accurate” way - and your idea of “loud” may be slightly different to my idea of “loud” (though generally people tend to agree more or less, so long as they do not suffer from hearing problems.

Well there is an “approximate” way that may be close enough. I wrote a plug-in that attempts to adjust the levels of tracks to about the same “loudness”. In my tests it is usually fairly close, but you can let me know what you think. The plug-in is available here: ReplayGain plug-in
The download to use is the link that says “New Version”.
The only documentation for that plug-in is in that forum topic.

The quickest way back to “normal” is “Shift+Right Click” over the vertical ruler.

That got it! Thanks Steve!

Peak level is NOT the same as “loudness”. Loudness is subjective, not an absolute measure. The only really accurate way to determine whether one track is louder than another is to listen to them.

Obviously, you are quite right. I was trying to determine the quietest one out of seventy. That is what I meant by it not being feasible to remember, for example, the volume of track 12 versus track 39. Guess I start at the beginning and go through them sequentially. I’ll check out your plug in - thanks for the tip.

and your idea of “loud” may be slightly different to my idea of “loud” (though generally people tend to agree more or less, so long as they do not suffer from hearing problems.

I’ve lost close to half my hearing, but loud is comparative! As long as all are at the relatively same volume, all will be well. The big problem here, of course, is that these tracks have been mastered by 70 different folk, so they are by definition going to sound ‘different’. But that is GOOD!

Thanks again Steve,

Bob

On two or thee occasions when playing a tune, it will just stop. Without touching the mouse, totally hands free. I go back to the song, and start it again, and it plays all the way through perfectly. This has happened on different songs, not the same one.

Any suggestions?

Bob

It just did it again. I was sitting on my hands.

If there is a “selection” (part of the track highlighted) then play will begin at the start of the selection and stop at the end of the selection.

If there is a “selection” (part of the track highlighted) then play will begin at the start of the selection and stop at the end of the selection.

Nothing selected or highlighted that I am able to see. I am playing heads and tails to compare volume … sometimes I let the entire track play through. Usually I listen to the first twenty / thirty seconds, and then to the last ten / twenty seconds, and then into the next one … it seems to be when I let the track play through when it happens. As long as it isn’t actually in the file, I guess it doesn’t matter.

Bob

Have you got all 70 songs imported at once? That might be asking rather a lot.

If you only have one track then what playback device are you using? “Audio to buffer” in Audacity’s Recording Preferences might be set too low - that setting affects playback too.


Gale

I mistakenly clicked on Time Shift and now cannot ‘unclick’ it. How do I do that? I looked in the manual, but it doesn’t seem to address that issue.
Thanks,
Bob

Have you got all 70 songs imported at once? That might be asking rather a lot.

Thanks Gale. I do indeed have all 70 tunes imported. So far this morning this stopping issue has not occurred … keeping my fingers crossed!

Bob

I am now at the Export stage. I chose Export Multiple from the File menu, and designated a Folder & location. After clicking Export, the Metadata box comes up, which gives me a chance to tidy up the info on each file. As expected, Track 1 came up first, and then track 3. As all my tracks are numbered sequentially, I cannot understand what happened to it. It is still present in the playlist.

I want to move on with this project, but am leery of going ahead and completing the meta data for all the files and then coming back to track 2, just in case something weird happens.

Help please !

Bob

I just scrolled down to Track 15 in Metadata. By the time I reached number 15, three tracks had ‘dropped out’. I haven’t gone on to number 70, but at this rate, if I had I am sure there would be many more missing. As I said in the last post, all these tracks are numbered sequentially, starting at 201 and ending at 270.

I am puzzled!

Bob

I mistakenly clicked on Time Shift and now cannot ‘unclick’ it. How do I do that? I looked in the manual, but it doesn’t seem to address that issue.
Thanks,
Bob

Incidentally, I resolved this by rebooting the program.

Bob

I just scrolled down to Track 15 in Metadata. By the time I reached number 15, three tracks had ‘dropped out’. I haven’t gone on to number 70, but at this rate, if I had I am sure there would be many more missing. As I said in the last post, all these tracks are numbered sequentially, starting at 201 and ending at 270.

I’ve been wrestling with these missing files for three hours. The project is finished and awaiting Export, but until I can figure out this glitch I am stuck.

Does anyone have an idea as to what is going on?

Thanks,

Bob

Time Shift and the other tools in Tools Toolbar are not a toggle. Once clicked, they are “on” until you click the button for another tool. So, click the I-Beam button to go back to Selection Tool.

I will try to make this clearer for the Manual for the next release.

Yes, restarting Audacity will revert to Selection Tool, unless you chose the last button (Multi-Tool) which remains selected after restart.




Gale