Error opening recording device. Error code: 0 Success.

Hello, I am trying to record my desktop audio on my Windows 10 device.

The sound is playing through my speakers just fine. I have checked and made sure that “Allow desktop apps to access your microphone” in Privacy settings is on. I have tried reinstalling audacity and am using 2.4.2. I have tried running audacity as administrator, I still gives the error.

Clicking on record button gives the following error:

Unanticipated host error

Error opening recording device. Error code: 0 Success.

Other settings:
Host: Windows WASAPI
Recording Channels - 2 (Stereo)
Project Rate: 44100 Hz

I am not sure why it has stopped working. I have been able to record just last month. Any help would be greatly appreciated

Are you using the computer’s built-in sound card for recording and playback?
If so, check in the Windows Sound settings that the device is set for a sample rate of 44100 in the Recording AND Playback tabs.

RoyalKnight’s problem is exactly the same as my own - I’m on Win8.1 Pro - ie the same error message.

I’ve read another thread along similar lines, tried uninstalling and re-installing 2.4.2, then 2.3.3 which I still had, then 2.1.3 which the person in the other thread found resolved the problem. All similar. And I was using Audacity 2.4.2 until a few months ago with no issues.

The speaker is playing fine, and I want to record something I’m playing on that. Used Audacity to do this for many years, so I don’t understand the problem. Also I’m not as familiar with Win8 as I was with “good old XP”.

So what to do? Audacity has been my go-to for many many years, and I’d like it to remain that way.

To get two present jobs done I’ll try different software. But having not found a fix in over 2hrs of tyring I’m now appealing for help.

Try [u]WASAPI (loopback)[/u]

Also, I’m not sure that it would make any difference, but check that overdub and software playthrough are off.

if WASAPI fails, try MME.

I hope this helps. :smiley: