Error message when importing mp3-file

How does importing of this file behave itself in the version 3.0.2? I mean, there’s never been a mistake like that before.

The latest release version of Audacity is 3.0.0.

Are you using “Audacity 3.0.2 alpha”, or “Audacity 3.0.2 rc02”?
Where did you get that version of Audacity from?

Note that pre-release versions of Audacity should not be used for production work. Any pre-release versions of Audacity that are made available through official channels are for testing purposes only.

We are not able to provide user support for any versions of Audacity that are obtained through unofficial channels as we have no way of knowing if they have been modified or infected with malware.

I’m using Audacity 3.0.2 rc02
I got it from the source:
It was adviced by one of your specialists. I’ll tell you more. This unreadable file is not the only one!

Thanks for the info.

That MP3 works fine for me with Audacity 3.0.2 rc2

First Track000.png

I’d sure like to know, why I can’t import. I downloaded the same file from the other site ( - error message again! Why won’t the program let it in?

I would like to know why as well. I tried it in 2.4.2, in 3.0.0, and in 3.0.2 RC02 with no issues - I am unable to duplicate the problem. Have you tried resetting your preferences: Tools > Reset Configuration or rebooting.

Since you shouldn’t be running production on 3.0.2, try it in 3.0.0 or 2.4.2. If you still have problems, try importing it with FFmpeg. see here:

If that doesn’t fix it, try converting it to .AIF in VLC, and importing the .AIF into Audacity.

I hope this helps. :smiley:

I would like to know why as well. I tried it in 2.4.2, in 3.0.0, and in 3.0.2 RC02 with no issues - I am unable to duplicate the problem. Have you tried resetting your preferences: Tools > Reset Configuration or rebooting. Readmore

Hi! I converted it with online converter. From mp3 to mp3, without changing, formally. Then, everything is fine. There is still a question about the original, nonconverted file. Audacity for some reason doesn’t recognize it’s format, as mp3. Though it’s really mp3. I tried importing it with mp3DirectCut - everything is fine!

The problem was solved unexpectedly. I just installed ffmpeg from the page:
Now the file is imported successfully.

Please, look! The line “Artist name” is…empty! Why does Audacity erase tag content? As in the imported file the artist name is properly written.

I cannot reproduce this error on my W10 PC - the Artist Name is present and correct in Audacity when I export an imported edited .mp3 audio file with metadata.


The problem repeated itself for the other file:
The line “Artist name” was…erased! Why is just this line and what could have happened? It began after installing ffmpeg.

That file has a stream error (The MP3 is slightly malformed).
Because of that error in the file, Audacity’s built-in MP3 importer (“libmad”) fails and passes the file to FFmpeg so that FFmpeg can try to import it.

FFmpeg is more fault tolerant and is able to import the file successfully.
Unfortunately, FFmpeg’s handling of metadata is not as good as libmad, so some of the metadata fails to be imported.

I’ll recheck that first file - Now that I know what I’m looking for I’m guessing that has the same problem.

Yes it has the same problem. Also it has garbage at the end of the file:

Analyzing file "Rio2.mp3"...
WARNING: "Rio2.mp3" (offset 0x287): MPEG stream error, resynchronized successfully
WARNING: "Rio2.mp3" (offset 0x3d7d05): Garbage at the end of the file
INFO: "Rio2.mp3": 9661 MPEG frames (MPEG 1 Layer III), +ID3v1+ID3v2, CBR, CRC

Thank you! But that’s never been such a problem in the version Audacity 2.2.2 (in one of the previous versions about two years ago, I don’t remember, may be 2.3.0, 2.3.1). Could it be a downloading error? Site doesn’t allow to download mp3, it’s necessary to install a special extension to browser.

You are correct. :smiley: Older versions of Audacity used to be more tolerant of mp3 encoding errors. But that caused other problems. In 2.4.2(?) file checking was tightened, although in 3.0.0 it has been eased back a little bit. It may be adjusted further in the future…

You’re right (and I don’t remember the exact version number either).

In old versions of Audacity, error checking was disabled in Audacity’s MP3 importer. However, it was found that some malformed MP3s could cause serious problems, so somewhere around version 2.2.2 error checking was enabled.

Unfortunately we then discovered that malformed MP3s are rather common, and received numerous reports of MP3s failing to import.
In recent versions of Audacity the error checking has been toned down so that most MP3s will still import even if they contain small errors. It is currently being discussed whether the error checking can be reduced further, but we need to be careful prevent badly malformed MP3s from causing serious damage to a project. Turning off error checking entirely would be dangerous.

I’ve not tried it on Windows, but on Linux I was able to fix the MP3s with “mp3val”.
(Mp3val is also available for Windows, but as I said, I’ve not tried it on Windows

No, it’s not a solution. Mp3val refuses to import the file:
Though the file “Rio” (the first) it corrected. Can you further give the user a choice in preferences to turn off checking imported files? As it does mostly harm rather than good.

Here is one more file:
All the same. Request to fix the bug without delay.

Analyzing file "A tam, vperedi, vsyo doroga1.mp3"...
WARNING: "A tam, vperedi, vsyo doroga1.mp3" (offset 0x479): MPEG stream error

This isn’t actually an Audacity bug. The problem is that you are trying to import malformed MP3s. It’s your MP3s that are the real problem. There is clearly a bug in the app that is creating those MP3s. You should be asking the makers of that app to fix the bug.

As I wrote previously, one of the Audacity developers is looking to make Audacity more tolerant of malformed MP3s, but doing that is not “fixing a bug in Audacity” but rather “working around bugs in other apps”.