Clip Fix only fixes part of the signal?

Hi there: I’m using the current version of Audacity on a 2006 Intel Mac running Lion (10.7), installed from the dmg file. When I work with a file that has clipping, I first run Analyze/Find Clipping…, then I go to Effect/Amplify and reduce the overall level by 5 or 10, then I run Effect/Clip Fix…but the result for track 1 (and maybe for track 2 also, I can’t remember) only reconstructs the clips on the positive side (the upward half of the waveform), not the negative side (the downward half, although a very small number of these do get reconstructed). Am I doing something wrong, or is this a bug, or is there some other explanation?

My thanks in advance!

Bill in Maryland

There’s not much official documentation for ClipFix.
Most of the information is at the top of the ClipFix effect screen:

Clip Fix attempts to reconstruct clipped regions by interpolating the
lost signal. Before use, reduce amplification by 10 dB to give room for
the reconstruction. > ‘Threshold’ is how close to the maximum sample
magnitude any sample must be to be considered clipped.
> If processing
is slow, select only a few seconds of clipped audio at a time.

Note the sentence that I’ve highlighted.
If the bottom of the waveform is clipped more than the top of the waveform then it may be “below” (closer to zero) than the threshold level.

Applying the “Normalize” effect with only “DC offset correction” enabled may adjust the waveform so that the lower peaks are the same height as the upper peaks.

If that does not work, undo the applied effects (Effect menu > Undo).
You could then try:
Running the effect once,
Then in the Nyquist Prompt effect run the following code:

(sum s -0.1)

Then run ClipFix again,
Then run the “Normalize” effect with “DC offset correction” enabled.

Note that ClipFix is not magic. If the audio is badly clipped then it will still sound bad after being “repaired”.

Thanks, Steve! I will try this as soon as I can and we’ll take it from there. Bill

Hi Steve,

I’m having a similar problem as described above, except that it’s with the right track (2). But otherwise same thing: The clips on the bottom half aren’t being reconstructed. It seems that the Nyquist Prompt code you recommend should be different for my situation, but I’m not sure how.



There is now a little bit of documentation in the manual:
Try running the Normalize effect to remove any DC offset (as described here: and then run ClipFix again and see if that works better.

Yep, I already tried removing the DC offset, but it didn’t help. That’s why I want to know what to do with Nyquist Prompt to move the waveform into an area that Clip Fix will treat.

One possible cause is that the audio in the right track may have positive peaks that are greater than the negative peaks. This would cause the clips on the bottom half of the right track to be “hidden” from ClipFix because they are at a lesser absolute level than the top of the track. To adjust this there is now a new tool that you can try called “DC offset…” You can get it here: (make sure that you download the “Current Version: dc-offset.ny”)
Use the following settings:

Apply or remove: Remove
Offset removal method: Equal +/- peaks
How much offset to add: doesn’t matter - we’re not adding. Leave at the default 0.0

After applying, try ClicpFix again. Does that work?

After applying ClpiFix you should put the “DC offset” right again.
Apply “DC offset…” again, but change the “Offset removal method” to "Dynamic.

Let me know how you get on.

Thanks Steve. What you recommended worked, in that it moved the waveform into an area that Clip Fix could affect. Unfortunately, the clipping must be too bad, because there were still the ominous red lines after I was done. Oh well. I can always re-record the music.

Is the track set to “32 bit float”? (look at the track information in the panel on the left end of the track).
For any audio processing it is better to have the track as 32 bit float, but particularly when using ClipFix.
If the track is “16 bit” or “24 bit” you should convert it to “32 bit float” before applying ClipFix. To do this, click on the track name and from the drop down menu select “Set Sample Format > 32 bit float”.

After applying ClipFix, use the Amplify effect to bring the waveform into the valid range below 0 dB. That should remove most if not all of the red clipping indicators. Then listen to the result to see if it has been adequately fixed.

Yes, if the track was badly clipped it may not be possible to fix, but it is worth trying :wink: