Clicks not showing up on waveform

The clicks on the example you posted are mechanical

So his phone stopped making mechanical noises when he turned its transmitters off?

Koz

To whoever said the clicks are mechanical, I’m not sure what to tell you. After thinking back to all of the times the clicks weren’t there it was every time that I was just testing a new mic out and wasn’t reading off of my phone. Then I would think the new mic solved the issue because there were no clicks…then the clicks came back when reading with my phone. The clicks have sounded the exact same with 3 different mics, including a high end xlr mic with good audio interface, and connected to an iphone or two different PCs (one a top of the line pc). After putting the phone on airplane mode the clicks went away on a recording that was 30 minutes long - never before had I gone more than 3 minutes without a click. It was the phone, hate to break it to you :stuck_out_tongue:

The clicks sound like the mic diaphragm suddenly flexing, having been tensioned by previous plosives,
like a spring-loaded mouse-trap being triggered, (in this case the trap is intermittently reset by plosives).

Now Tylertrue1 has replaced his 35$ mic with a “high end” mic could explain why the clicking has gone.


If it was sound from the phone they would have noticed it: the click would be like the tick of a wind-up alarm-clock.

I’m not saying phones cannot create electrical interference, but it does not sound like this …

The high end xlr mic did the same thing. As did my mid level USB mic and cheap mic. The only common thread in each setup I had was reading from the phone. Anyway, I’m just trying to help anyone else out with this problem. This is 100% what it was. Nothing mechanical about it, no matter how it may sound to you.

Or it’s possible that the recording I sent you was a mechanical click from that first cheap mic I was using and there were interference clicks as well in that recording (there were clicks at least every couple of minutes). And then it was just interference clicks on the next two mics I was using. Either way, a better mic and phone in airplane mode has stopped the clicking. That’s the important part.

Okay I have been having this same issue and I only notice the clicks in spectrogram form. The thing is I noticed they basically only appear when I try to delete or add “good noise” to an area with a heavy breath or any other bad room noise—or any edits really. By deleting or pasting new audio into my recording, little blue spikes will appear out of nowhere and make pop noises. The weirdest thing is that if you delete the spike it sometimes just creates another one endlessly, like a whack a mole. Anyone have any advice on this?

Your audio may have “DC-Offset” (see: DC offset - Audacity Manual)
If it has, then you need to fix that before you start editing.

Interesting thank you for the response. All my equipment is brand new I’m wondering if this means I need to replace my audio interface or if it is a common problem that can be fixed purely in the editing process?

So I actually just read through the dc offset page you linked and tried to apply the fixes but my audio is actually level at 0 and not offset, and cutting and pasting still creates the spikes. Any other possible solution you can think of?

Clicks can also occur if the audio contains sub-sonic (very low frequency) rumble. That can be fixed by cutting the very low frequencies with the “Filter Curve EQ” effect.

If it’s a speech recording, there is a preset “Low frequency roll-off for speech”.
If it’s a music recording, it would be better to cut off just the extreme low frequencies (below about 40 Hz).

I actually need to correct what I said. I take everything back. The phone on airplane mode didnt fix anything. The problem the entire time was that my gain was set too high. The computer couldn’t handle the usb mics and the audio interface couldn’t handle the xlr mic with the high gain I had, which was almost maxed out. I didnt think that was a problem because the end recording was close to what ACX requires and I didn’t need to amplify much, but apparently it was everything. I turned the gain right down and then just amplified the sounds like crazy, no more clicks. I couldn’t have done this before when recording in my home but now I’m renting a studio with low noise floor so I can do it. What a nightmare this has turned into. Why cant people just read instead of listening to audiobooks? Ahahah

:smiley:

OMG turning off Low-rolloff for speech EQ before making my edits seems to have totally fixed the problem! seems too good to be true but so far so good. Thanks for the tip!

the end recording was close to what ACX requires

Nobody can read directly into ACX, or if you do, it’s by accident. It is recommended that you record at a lower volume and let Audiobook Mastering make up the difference.

This is the current recommended goal.

StandardRecordingLevels-650w.jpg
Occasional recording tips up to about 50% or the bouncing sound meter just turning yellow.


turning off Low-rolloff for speech EQ before making my edits

Do your editing and production before Mastering if this works for you. Then, when you get a chapter working, apply Mastering. It’s dangerous to apply the Mastering steps out of order, add any, or leave any out. They clean up after each other.

Cutting and pasting silence to cover up errors can be a recursive problem. If you edit after mastering, your silence has to have Low Rolloff, too, so it matches. If you edit before Mastering, then you should use raw silence.

Home microphones almost all have very low pitch noises and rumble. If you don’t get rid of it in editing, your show may fail on really good sound systems or good headphones. “What’s that thunder or growling noise in the background.”

Also, not using Low Rolloff will throw the audiobook RMS (Loudness) and Peak settings off.

The three audiobook Mastering tools are a suite, a harmonious grouping.

And just when you thought it was safe, DeClicking and DeEssing work much better after Mastering.

Koz

Do your editing and production before Mastering if this works for you.

I think there is a misunderstanding. As far as I know, low roll-off for speech EQ is the first step for mastering an audiobook (followed by loudness normalization and limiter) for ACX. So for me, doing mastering first and THEN doing the editing seems to be the best solution to prevent pops and clicks from popping up when I delete, cut, or paste audio.

Use the low roll-off for speech EQ first, then do your editing, then do the remaining “mastering” steps after your editing is complete.

So the low roll-off EQ is a good bandaid fix for now but this is still really bothering me! I will link a video to the problem so you can see it and maybe give a better assessment? I have tried plugging into different USB ports, using different aux cables, reinstalling audacity, and using a completely different interface but the problem persists.

It won’t show my edit toolbar in the video but the only actions I’m performing are “deletes” and one attempt at the end to try and paste clean noise over a spike. It just keeps making more spikes!

https://www.youtube.com/watch?v=ij4Ty43oU3k

Just before you hit delete, hit the “Z” button on the keyboard, that will adjust your selection to “zero crossing points”. Then when you hit delete there should be a smooth join, rather than another discontinuity click.
https ://manual.audacityteam.org/man/select_menu_at_zero_crossings.html

[ BTW you should reset your toolbars: avoids wasted screen space].

So pressing Z doesn’t seem to do anything, do I need to set anything up to make Z a hotkey or enable the zero crossing points edit you speak of?

EDIT: it looks like pressing Z does actually change my selection slightly when zoomed in, but the problem in my video persists. Deleting still creates a new waveform peak rather than just removing it.