Audacity MP3 doesn't play on MP3 player [SOLVED]

Quick question. I have been using Audacity for over 15 years and have been successfully exporting files to MP3 which I can then play in my car via the built-in hard drive. This week I got a new computer and downloaded the latest version of Audacity (2.0.5) (WIN 7) previously I had version 1.3 Beta.

I have tried all kinds of ways but the MP3 file produced plays perfectly on the computer but does not play in the car. You can see it in the car but when you select to play it the next song plays as if it either cannot see it or is unable to read it.

Are there different types of MP3 files? Should I be using a different Lame file?

Thank you

MP3s can be CBR, ABR or VBR. The default is CBR, as it was for Audacity 1.3.x, so that would not seem to be the problem unless you have manually change the MP3 options.
How are you getting the MP3s from your computer into the car player?
Have you checked that the hard drive in the player is not full (or nearly so)?

No the car HD is not full you can see the file there it’s just when you select to play it goes to the next one.

Also what should be the Host setting: MME or WASAPI?

Forgot one thing. Is there some way I check for the MP3 setting?

You can see a “file name” there. Can you be sure that the entire full length file is there?
How are you getting the MP3s from your computer into the car player?

It depends what you are recording, but that is not relevant to MP3 export. If the MP3s play on your computer then they are most likely OK.

To select the MP3 settings, in the Export dialog, select MP3 as the file format and then click on the “Options” button: Audacity Manual

Not only can I see the ‘Name’ of the file the file plays on the computer.

I copy the file on a USB and load it into the car.

I checked options on the Save As MP3 dialog box and it just showed bit rate but not the type of MP3

“Constant” (selected above) is “CBR” (Constant Bit Rate)
“Average” is “ABR” (Average Bit Rate)
“Variable” is “VBR” (Variable Bit Rate)

The “Presets” are also “VBR” (new style names recommended by Lame).

Do you have any old MP3s on your computer that you can try loading onto your car player? That may indicate whether the problem is with the new MP3s or whether it is something else causing the problem.

First of all all the old tracks loaded play. I copied another old MP3 track from the computer and loaded it and it plays fine.

Could it be the 2.0.5 version?

That’s good news.

I wouldn’t have thought so.

If you could send a couple of files via a free file sharing site (such as dropbox or sendspace), one good one that plays and one bad one that doesn’t, I’ll have a look to see what the difference is.

Okay I am sending a dropbox link to 3 files 2 do not play (created on the new computer) and one that does play and created on the old computer. I used Stereo Mix on Recording and one when I disabled Stereo Mix.

2 differences between the one that plays and the two that don’t:

The one that plays is “joint stereo”, the two that don’t are “stereo”.
“Joint stereo” usually gives slightly better overall sound quality. This is probably not the problem, but since your player supports joint stereo I’d recommend setting that in the MP3 options.

The one that plays has a sample rate of 44100 Hz, the two that don’t have a sample rate of 48000 Hz.
This is most likely what is causing the problem.

The default sample rate is set in “Edit > Preferences > Quality”. This sets the default for recording and 44100 is normally recommended unless you are working on audio for DVD, recording bats or other ultrasonic sounds (with appropriate hardware) or have some other special reason to not use 44100. I suggest that you change this to 44100.

Regardless of the default sample rate, the actual sample rate used when exporting is set by the “Project Rate”. This can be found in the lower left corner of the main Audacity screen. Before exporting, ensure that this is set to 44100 (if it’s not, change it to 44100 before you export).

I am able to make audio files in my old computer which is Win7 using version 1.3.13 beat and they work fine.

I loaded version 1.3.13 on the new computer which also has Win7 and it does not create playable audio files.

I created an .aup file in the new computer and copied it to the old computer and Exported it from there. The file created was unplayable. So clearly there is a Win7 setting which needs to be tweaked in the new system.

Please try Steve’s suggestion. Set the project rate bottom left of Audacity to 44100 Hz. Then open Edit > Preferences, choose Quality on the left, then set Default Sample Rate to 44100 Hz. That way, your new projects will always be 44100 Hz. We have established that your player plays MP3 files at 44100 Hz.

Are you adding metadata to these MP3 files when you export them? Your Dropbox links are dead now, so I cannot obtain the files.


What is the difference between WASAP and MME?

Thank you changing it to 44100 did the trick.

I did notice that in my old computer it was set to 41k.

Valid sample rates per the MP3 specification are (Hz): 8000, 11025, 12000, 16000, 22050, 24000, 32000, 44100, 48000.

As this issue is solved I am locking this topic now so that it does not drift into other discussions.


That is a separate topic, please see: Recording computer playback using WASAPI or MME .