"Audacity is already running" error [SOLVED]


While I was using Audacity, my computer shutdown a couple of times and when I went in to open my file again, I keep getting this message: “Audacity is already running. The system has detected that another copy of Audacity is running. Running two copies of Audacity simultaneously may cause data loss or may cause your system to crash. Use the New or Open commands in the currently running Audacity process to open multiple projects simultaneously.”

Audacity is not open and does not show up in my Force Quit Applications bar.

Looking online for a solution led me to trying to find an Audacity temp folder and though I have looked and tried various commands in Terminal, I have not been able to locate any temp Audacity folders under any name.

How can I fix this problem?

My OS version is 10.11.1
My Audacity version is

Yes it is probably an old “lock file” that is still present.

In Finder, Go > Go to Folder and type or paste:

~/Library/Application Support/audacity/

Click “Go”.

In the “audacity” folder that opens, open the “audacity.cfg” file in TextEdit and look for the line underneath [Directories] that starts with TempDir=. Carefully select and copy everything after the equals sign. Mine is var/folders/c0/8p18hd453p3_433cf9_595b40000gn/T/audacity-gale.
From Audacity 2.1.3, Audacity’s default temporary directory is at /Users//Library/Application Support/audacity/SessionData.

Then in Finder, Go > Go to Folder, paste in the path you copied and click “Go”.

In the folder that opens, delete the file “audacity-lock-”.


You should find out why your computer is shutting down.

Open /Applications/Utilities/Console.app for reports as to what might be the problem. Do you have external hardware connected to the computer?

To begin with, you could open /Applications/Utilities/Disk Utility, select the drive you are using and press the “First Aid” button.


Thank you!

I did everything you said and it all worked. No more error message…

But Audacity won’t open now. I tried restarting my computer and nothing. When I click on a file or on the application itself, nothing happens. Down in the dock, the application bounces once and stops so it doesn’t even try to pretend it’s opening.

What do I do now?

Either delete the audacity.cfg file whose TempDir line you copied, or just delete that entire TempDir line. See Fix for Audacity 2.1.1 not launching



Thank you thank you thank you!

Everything works and opens and I can hear what I recorded and the icon bounces and I might actually be able to graduate!

Bless you, Gale Andrews, you exceptionally intelligent and kind human!