Audacity doesn't run at all.

Hi. Installed Audacity 2.2.2 using the .dmg, but it never launches on my iMac, just immediately quits. I’ve also tried the current alpha, as well as the previous version but with the same result.

I’m using macOS 10.13.6, and the iMac is an i5 from 2017 if that makes any difference.

I’ve got Audacity running fine on my 2015 Macbook Pro.

I’ve tried the suggestions in this thread:

But unfortunately they didn’t help.

Not sure, but the problem could be that my entire user folder is located on an external SSD, connected with USB 3.1 via the thunderbolt port. This has never given me any problem with any other program though, but it’s the only thing I can think of that might make my setup different from most other users.

So to summarise I got the macOS system and Audacity (as well as every other program) installed on the built-in 250GB SSD. And I have my user folder located on an external SSD drive.
I have of course tried installing Audacity on the external drive as well (/users/myusername/Applications/). But that didn’t work either.

Just a guess. Not sure that it’s related at all :slight_smile:

Any help would be appreciated :slight_smile:

Based on my experiences, the location of your home folder is the likely culprit.

Please see the following thread:

I’m happy to assist further if you aren’t able to resolve your problem after reading through it.


Thank you! It seems like we have very similar setups.

I chose to copy the audacity folder to the ‘Shared’ user-folder on the internal SSD. It appears to be working just fine now :slight_smile:

Good idea. That makes for a quicker and easier fix. Thanks for sharing that.

On a side note, I ended up setting my Home folder on the SSD boot drive. Only the Library folder lives there. All the other default folders Documents, Music, etc, are symlinks to folders on the mechanical drive. Having the user library on the SSD significantly improves performance on my machine.

For anyone reading this, I don’t recommend using a symlink to a user library outside of the defined home; the defined home folder should contain the actual library. Most things worked, but I found problems with Spotlight that adversely affected searches in Outlook 2016.